My s49 Mk1 Komplete Kontrol 1.9 Automatic Track Focus doesn't work

This just started today, out of the blue, after working for quite sometime. It looks like the remote setting for Kompete Kontrol does not stay selected anymore and keeps resetting. Something must have changed on my system and I have no idea what, unless there was a silent Windows update that has caused a conflict.

welcome to the club AAMedia. Reinstalled Komplete Kontrol a couple of times but didn’t help. This just came out of the blue for me as well a couple of days ago. I also removed other remote controls but still no luck. I have issued a tickets at Native Instruments but no progress yet.

Any update on this Steinberg?

i have installed Ableton just to check if the Komplete Kontrol keyboard is functioning as planned and it works. So logically this would be a Cubase issue why its not working and not a Native Instrument problem.

Can you please support/assist in solving this?

by the way I’m running 9.5.20.

Did this ever get resolved?

I’m having this issue now with Cubase 10 & Komplete Kontrol S49 :frowning:

Hello,

I would like to share a small experience and make it useful to users who, like me, have a problem with the malfunction.
from Komplete kontrol auto focus in Cubase, this is how I solved the problem for me.
First, I bought the Komplete Kontrol S88 MK2 in August 2021. Initially everything worked normally with Cubase Pro 11 and after a while,
(2 months approx) the auto focus no longer worked. Nothing more annoying than having to take the mouse back to manually reactivate it each time you
changes tracks, especially since the goal of Native Instruments keyboards is to use the mouse less. I searched for a long time on my pc and on the internet
what could come of it but in vain, until the day when I had to reinstall windows for a material reason. And then everything works again, great, but that’s it
won’t do it if you have to reinstall Windows and all the software (and I have some!) every time you lose auto focus, it takes a lot of time.
So I make a system backup on another hard drive to simplify the reinstallation in case… So time goes by without worries until the day
or I’m updating Cubase Pro 12.
At the beginning of the update everything works, but as I like to fiddle with all the parameters, especially with the new Midi Remote, that’s where: “and pafff!
again, manual focus!” I may have done something wrong, so without wasting time I restore my pc with my system backup made when
everything was fine (about 30 minutes, it’s better than hours and hours) and reinstall Cubase Pro 12. But to my surprise after restoration, manual focus again!
I thought that the cause could come from a file on the system disk and well no. You have to look elsewhere. And that’s when I started to understand
where it could come from, there are not 36 places. If the error does not come from the system disk, it can only come from the “Documents” folder because I had changed
its location on another hard drive. So by putting its subfolders likely to cause the error one by one to the trash (without emptying the trash of course
to be able to restore them later) and by restarting Cubase each time, I managed to identify where it came from. The culprit (finally the culprit
in reality it’s me but I’m coming to it) it’s the “VST XMLs” folder or rather what’s lower in the folder tree. It is a file named
“Generic 8 cells”. This file is created when modifying the instantaneous Quicks Controls assignments of a VST in Cubase. If most VSTs do not cause problems
with these modifications, Komplete Kontrol meanwhile does not appreciate these changes and suddenly loses the auto focus by switching to noon. On the other hand, none
problems with the instant Quicks Controls of the track. This file must therefore be deleted to regain auto focus with new Komplete Kontrols tracks,
as for the Komplete Kontrols tracks already created, you can only find the auto focus by reloading Komplete Kontrols in the track inspector.

Here is the file path:
In my case it is:

“F:\Documents Arnaud\Documents\VST XMLs\Native Instruments GmbH\Komplete Kontrol\5653544E694B4B6B6F6D706C65746520”
and delete the “Generic 8 cells” file

In other cases, likely to be:

“C:\Users\Users\Documents\VST XMLs\Native Instruments GmbH\Komplete Kontrol\5653544E694B4B6B6F6D706C65746520”

There you go, if it can help some, so much the better. I took my head and time enough to find the cause of the problem. maybe it’s not a big deal,
but when you don’t know well … we search, and we search again, and we get angry!
Computer music is very good, it’s powerful, but when you start trying to solve what’s wrong, it takes time and that time isn’t music.
With that, good day and good music.

4 Likes

I’m glad to see someone else had come to the same conclusion as I did a few years ago.
Back in October 2020 I had a long back and forth with NI support about this issue and it was left unresolved.
In the end, I re-installed Windows 10 a number of times and came to the conclusion that the issue was related to re-locating the Windows system folder “My Documents”, something I do automatically when I install an OS fresh. I sent my findings to NI, but never got a reply back.
@Arnaud88 thanks for drilling down even further and finding the exact culprit!

Unfortunately my S61 MK II seems to have taken a complete crap as of a couple of weeks ago where the two displays are not updating at all anymore. Not even when running Komplete Kontrol as a stand-alone.

Hello mlindeb,

It’s sad to see that NI support couldn’t solve this problem. As software developers,
they are still much more competent than us users to detect this kind of problem.
When you invest a certain sum in this kind of material, you only ask for complete satisfaction.
I’m sorry for your S61 but suddenly it scares me a little me who just bought the S88 955 euros…
Maybe there is an update to do? How long was your keyboard in good health before it started working less well?

I bought the S61 MKII in the end of 2017, so it’s not exactly brand new. But, it hasn’t been used all that much tbh. The keybed and controllers are what I initially bought the keyboard for and while I was intrigued by the Komplete Kontrol concept, the implementation and workflow never resonated with me.
The screens stopped syncing with the software a few weeks back, I thought it was the Cubase 12 install, but it didn’t work with the stand-alone version of KK so it’s probably not that. I don’t have the energy to spend days troubleshooting that keyboard again for a few features I hardly ever use anyway.
Just to be clear, I haven’t heard of anyone else with the same problem as I have (screens not syncing, but everything else is). I would still recommend their controllers. The semi-weighted Fatar keybed feels great as well as the mod-wheel and pitchbend-wheel. I like the endless encoders and the touchstrip is a welcomed addition that gets a lot of use (even though it’s hardly ever assigned in any of the 5 billion+ presets. Why?). Their customer support, although not able to identify the real cause of my issue at the time, were timely and friendly in their correspondence. I wouldn’t feel concerned if I were you. :slight_smile:

Indeed if you don’t need KK, the main thing is that the keyboard and the knobs work properly.
Yes I completely agree that they are good controllers at Native, and their software too. I had read a lot of positive reviews.
on their qualities, that’s what prompted me to buy this keyboard and Mashine MK3 which is also excellent. I have other controllers from other brands
who do not have this quality. There was just this little auto focus mishap but it is now resolved. It bothered me a bit because I like
Cubase. And then there are enough customizable parameters in Komplete Kontrol so that we can do without the instant VST Quicks Controls, so nothing serious.
It was just to be able to extend the possibilities of the controllers.
I’m happy to read good things about the NI service because I had seen reviews saying the opposite. So that’s still reassuring in case
of problems.
Thanks to you.

Thank you very much Arnaud for your resarch, it works for me too!!
It is really very big and important discover for all KK users, was 2 years
in troubles with this issue, now Im really happy!!!

Hello Alès_Zibelnik, I’m glad it can help. But after some research in Cubase, there is something easier to do. If you change the assignments of instant Quicks Controls VST, it is better not to change the parameters of page 1 but only from page 2. At this time, you switch to midi which is normal. And going back to page 1, we find Komplete Kontrol and its auto focus. If on the other hand the assignments of page 1 have been changed, therefore loss of auto focus, just open “Remote Control Editor” with a right click on the VST plug-in and click on the small arrow at the top right and select “Use factory default” and “apply”. In this way, the “Generic 8 Cells” file will be deleted automatically and return of auto focus. So be careful not to change the assignments on page 1 because if you delete the “Generic 8 Cells” file, all the assignments from page 2 will be deleted too.

Be careful not to modify the assignments of page 1 because if you delete the “Generic 8 Cells” file, all the assignments of the following pages will also be deleted.

Do you mean pages on KK controler settings or new Midi Remote settings in C12?
I set my endless potis to Quick controls 1-8 on page 1 of KK software and I dont lose autofocus even if I switch on keyboard from Plugin view to midi CC view and back again…
Sorry, you want to help but I dont understand what you want to explain…
Maybe you mean old legacy Cubase quick controls which I never used.

I tested after I deleted that xml file,
and my project that I did with broken autofocus is still broken, but when I open empty project and open more KK instances autofocus works OK.
Do you have also some trick for such broken autofocus project?:grinning:

for old projects, you have to reload Komplete Kontrol in the track inspector to find the auto focus as explained in my first comment.
But follow my last comment, it will go faster. Page 1 of the “Remote Control Editor” must have the default assignments and everything is in order. I tested it and it works. :slightly_smiling_face:

not the KK pages but the Remote Control Editor for instant VST Quicks Controls

By restoring the default values of the Cubase Remote Control Editor, all your old projects broken with KK will be repaired automatically, hence the interest of doing it like that.

I ll try it tommorow, thank you!

Ok you will get back to me tomorrow

I’m still on cubase 9.5.
Can I fix autofocus on this way on that version?
It sounds awfully complicated and I’m a fried if I tried to do your advice id ruin things further. I’m not a computer nerd or coder so just talented at GUI and above level.
Never used smart controls in cubase or edited NI gear with remote control editor….
Just want to fix my autofocus…
Btw I only have an s49 mk1