N 5.5 - BUG? Crossfade window and Undo

After installing 5.5 today I tried working with it for a while. First thing I noticed is that selecting multiple clips and hitting “X” to apply a standard crossfade forces the crossfade window to pop up. It never used to do that and I must say it’s pretty annoying having to click on the close button all the time.

Even worse: “Undo” doesn’t undo the crossfades I just made. Weird. Can anyone repro?



tested on win7 64
n5.5 64

crossfade “x” key does not open the fades window

undo does undo the cross fade

maybe you have something going on in your prefs?

Thanks for your reply. But no, the common prefs for 5.1 and 5.5 are exactly the same. I’m on OSX though.

I have installed N5.5 and am running it on OS 10.6.8.
Hitting “x” does crossfades without opening the fades window.
Undo function works fine.


This is definitely worth exploring some more.
Does this happen ALL the time?
What happens when you try and undo? I’ve seen a strange behaviour myself - and will try report it when I get a better repro.
Cheers, Brendan.

We are discussing overlapping audio events, do we ?

Maybe it does have something to do with my prefs. I just deleted my Defaults.xml and tried crossfading a bunch of events in one go and it worked. But as soon as I changed the length of a crossfade and saved ‘As Default’ I got the same problem again. The crossfades do not appear in the History and can not be undone.

I don’t have time to screw around with it right now, because I have work to do, but as soon as I have a moment I’ll do a clean install of 5.5 and see if that helps.

Today I decided to see if re-installing Nuendo 5.5 would do the trick, but it didn’t work. Same thing happened. And like before, trashing defaults.xml seems to help at first, but saving a crossfade as default makes it do the same thing all over again. Annoying, because I would really like to try 5.5. Am I the only one having this problem? Weird. It must be some stupid preference file or something… Anyone?

Yes I got the same on OSX 10.6.7
I have yet to try the hotfix or even read about what it’s supposed to fix, will do that ASAP.

ErikG, glad you can confirm this problem. Might be Mac only. Thanks for pointing out that there is a hotfix. I just installed it, but unfortunately the problem didn’t go away.

Is there anyone else out there that can confirm this bug? Then please let us know. It would help convince Steinberg that we need this to be fixed.

ErikG, how are things on your end? Is the problem still there or did it go away after installing the hotfix? I’m still on 5.1 because of it. And are we the only 2 affected by this cross-fade bug?

I guess I’m alone on this one. Too bad. I’ll wait for version 6…

No problem still here as Well.
Can’t pin it down yet. Prob only a OSX issue.

Too bad it didn’t work for you either. Hopefully more users will chime in so we can get to the root of this.

The problem still seems to be there after the hotfix.

However, after doing a clean rebuild of ALL my prefs (I simply renamed the current prefs “OLD” and restarted nuendo) the problem disappeared. This does NOT explain why the prefs get muddled up, but it does seem to fix the issue. To me, the bug lies not just in what we are seeing, but in nuendo corrupting the pref files somehow. I wonder if this happens at “update time” or somewhere else along the while.

And as an added bonus, it made some other strange behaviors go away as well.

I realise having to go back to square 1 with prefs is a pain (!!!) but it seems to be well worth it.

Report back how you go with that. (Even if you just TEST with new prefs, but don’t have time to rebuild - you can easily go back to your old ones!)

After seeing this, I have rebuilt my prefs (which took a while) and then saved a copy of them, just in case I start to see the bahaviour once more - in which case I’ll just try copy in my saved “clean” prefs and see if that fixes things.

Cheers! Brendan.

Cheers, Brendan.

Hi Brendan,

I just tried your suggestion. I had to move the prefs of my 5.1.1 version somewhere else to be able to do a clean rebuild, because Nuendo automatically looks for older versions and copies the settings. So after taking care of that I created a clean version of Nuendo 5.5.1.

Then I checked the crossfade behaviour. It seemed to work, but, like before, changing the standard crossfade (making it slightly longer for instance) and saving it ‘as default’ screws it up again. Man, this is driving me nuts!

Could you check what happens if you edit the standard crossfade and save it as the default one? Thanks.


  • UPDATE -

Everything’s fine after installing 5.5.2! Finally…