N11 CPU spikes only with my Focusrite's drivers, not other drivers

I’ve read numerous threads about CPU spike issues, but I haven’t seen a problem quite like this one mentioned.

I’ve always had to put up with random CPU spikes with my Focusrite 2i4 –until one day—
Instead of running the Focusrite ASIO drivers, I switched to the generic low level ASIO driver.
CPU spikes gone. Completely. Even on the Focusrite.

Unfortunately it’s only half a win. The generic ASIO drivers only let me use the Focusrite when it is set to 48kHz. As soon as I set the Focusrite to 96kHz it vanishes from the list of devices in the generic driver, and the generic driver automatically switches to a different device if the Focusrite is selected. Of course, a bunch of my projects are at 96, so it’s not ideal to load them at 48 and play back at half speed…

But this does have me wondering if the CPU spike issue is driver related, maybe switching sound cards to a different brand would have better luck. (After trying latencymon, different configs, other DAWs, and finding nothing wrong with my system, I have to narrow this down further).

If I could only get the generic drivers to work at 96kHz I’d be quite happy. Hmm.

Honestly, that’s one of the more basic… entry level audio interfaces. There could be a firmware update, or driver update… but it’s also worth upgrading just for improvements in preamp and converter quality. If your suspicion is the card… I’d follow that and get a replacement.

UAD Volt are affordable and great. Of course, Steinberg also makes a good mid-tier device with Neve design transformers (or something like that).

Same here with scarlett 18i8 in windows 10 and Nuendo 12.
I set the buffer size to 512 to avoid the cpu overload message.
I have the last driver release. And I have the same issue with the desktop and the laptop.

Sadly some interfaces just don’t have great drivers, and this can cause issues. My knee-jerk response is “get an RME” because that will fix the problem but I fully realize they are way too expensive for most people.

In terms of the generic drivers, you can try ASIO4ALL. Steinberg’s generic driers are not great, ASIO4ALL is better. It may solve your problem.

As others noted, higher buffer values might do the trick too, back when I had a 6i6 I set the buffer all the way up. Now with my RME I can turn it down lower, if I wish.

Finally if you have a 1st generation Focusrite, the new 3rd generation ones do seem to work a little better. Personally though, after going RME I’ll never go back, despite their expense.

Yeah, it’s a first-gen. I tried Asio4all and unfortunately it didn’t seem to work as well as the generic drivers.
However, I uninstalled and then reinstalled the latest Focusrite drivers (with safe mode). I also set Nuendo to 64 bit floating precision. Right away there was less of the problem. Then I turned up the buffers (not ideal. but I do production, not audio recording, so it’s not the end of the world) and it was reduced further.
The problem isn’t gone, but it’s reduced significantly now. I still get CPU spikes but they don’t seem to interrupt audio as much.
(By the way, I did originally try a Steinberg interface with this computer when it was brand new, but for some reason I ran into a chipset incompatibility and had to replace it. Too bad–I much preferred the Steinberg interface).

I mean, it sounds like you’re just using a driver/interface that’s perhaps a bit inefficient and are using a computer that’s not fast enough for 96kHz work with your particular set of workload.

Generally it’s good to put computer specs in the sig so people can click and see real quick if there’s a bottleneck in hardware. So… what’s your computer setup?

I have an 8-core i7 workstation with 128GB of ram that I use for larger kontakt and orchestral tools templates. (The steinberg card problem was with the chipset on my ASUS x99 deluxe motherboard–I worked it out with Steinberg support long ago).

The CPU spike problem happens regardless of the size of my session, whether it’s my orchestra template that has 2500 midi channels running purged instances of kontakt (which seems to load the CPU up about 50%), or a nearly empty session with like maybe 5 channels of audio at 96kHz.

It also only happens in Nuendo. I have no problems in other DAWs (I use a few others depending on the project–Nuendo tends to be where I go for final production though). This lead me to believe it had to be some kind of problem between the Focusrite drivers and Nuendo, but of course, I can only guess via elimination.

So far, the two biggest things that make a difference are the changes I made above, and rebooting my computer. Turning off /disabling network devices, running latencymon, disabling any unneeded services, unfortunately none of that has helped

Well, it still doesn’t tell us much. Is it a Xeon part on x99 or is it like an 8700K?.. My hunch is still that the CPU might be just a bit old for this - although I agree that a ‘nearly empty session with like maybe 5 channels of audio at 96kHz’ seems like it should run without any problems.

Actually, if it’s an older CPU, what’s your OS and Nuendo version? Your configuration is supported, right?

Sure. It’s not a xeon but an i7, and a 6900k which is very comparable to an 8700k on most benchmarks. I’m running Nuendo 11 on Win10 updated last probably two months ago.
I should mention that this has been a problem for a while, even when the CPU was fresh out of the box.
Also, if it was the CPU, I’m not sure why the cpu spikes go away as soon as I switch to the generic drivers.

I think the reason you don’t see it in the generic driver because one there is probably a higher buffer getting set, but also because the Focusrite might just not have the greatest ASIO driver.

Oddly enough the input/output latency reported by the generic drivers is about 3 steps below the the max buffer/latency settings via the Focusrite drivers (where cpu spikes still happen, if reduced)

It really sounds driver related, doesn’t it.


Did you do a complete cleanup ?
I mean not just reinstalling the driver, but the following steps :

  1. Unplug device
  2. Uninstall driver (via Windows programs)
  3. Search for leftovers in Program Files (both), Common Files, ProgramData, and AppData folders, and delete them if you find any.
  4. Open Device Manager, show hidden peripherals, and remove the Focusrite device plus the corresponding audio channels (if you find duplicates please remove everything)
  5. Restart your computer
  6. Install the latest driver
  7. Plug your device

If it still persists, then you probably own a product that is from early release and did not benefit from subsequent revisions, or, only this particular model is affected.

Ultimately, and that’s generally the source of issues like the one you are experiencing, you have programs running in the background that affect the performance of real-time audio.
Could you please share a screenshot of Task Manager when Cubase is running, so that we can see what’s going on ?


After running these steps my problems were reduced by far the most.
The now very occasional spike on the graph does not even interrupt the audio.