naming files during render

I have a montage with 10 files (reigns with cd markers on the same track), and the CD tracks are named as CD text. I am trying to Render all the tracks at the same time with the output file to be the CD Track Name.
Doesn’t work.
Any advice how to pickup the track name automatically for output name?

Are you using WaveLab Pro? What are you currently getting for file names and using what render settings?

I always make sure the marker names match the CD-Text Track Name and render using the Render Source of All Regions/CD Tracks. This produces file names based on the Marker Name for each song/track, and using the Naming Scheme option in the Render Ribbon Tab, you can add a numeric prefix to the resulting files so your file names look like this:

01 Track Title
02 Track Title
03 Track Title

With the right workflow, this is done in a matter of seconds:
https://www.youtube.com/watch?v=7yH8-ZFSfFk

Justin, that worked. Thank you!

Can anyone please confirm that the OPs original problem is a bug? When using the naming scheme the CD text track title is NOT recognized for the file name. Already the preview in the naming window does show the result of my naming scheme Artist-Album-Number-TrackTitle without the Track Title. I quadrupplechecked the CD Text is correct.

No known bug. It works here with 10.0.40 and these settings: