nanoKontrol2 no longer working

I was using a Korg nanoKontrol2 USB controller with Cubase 8.5 prior to upgrading and it was working fine. After the upgrade to Cubase 9 it’s no longer working and I assume it needs to be reconfigured. Unfortunately, following the Korg instructions, I cannot get it working.

I’m using Windows10(64-bit) and Cubase9 Artist. The nanoKontrol2 is listed in Windows device manager. I’ve connected it when Cubase9 is running while pressing the SET MARKER + REW buttons and I get an audio ‘ding-dong’ tone suggesting it’s connected. I went to Device Setup and added a Mackie Control. I then went to the Midi input / output pull-down menus to select nanoKontrol2 … BUT THEY ARE NOT THERE!!!

There are no entries for the nanoKontrol2 in either menu.

Here are Korg’s instructions for Cubase:

  1. While pressing and holding down the SET MARKER and REW buttons, connect the USB cable from your computer to the nanoKONTROL2.

  2. Open the “Device setting” window in Cubase, and add “Mackie Control.”

  3. Select nanoKONTROL2 for the MIDI In/Out ports used by “Mackie Control.”

Any idea what’s wrong?? It’s the kind of thing that once it’s configured it just works and you forget about it. But now I need to get it working with this new version of Cubase and I’m stumped.

Any help would be appreciated.

Russell

I have a microkey air and had a similar issue. I had to use Korg’s uninstall midi driver utility to uninstall old midi drivers I wasn’t using. Then Cubase could see the microkey air.

I uninstalled all the Korg driver/software and followed the tips in the following Youtube video:

https://www.youtube.com/watch?v=s9OfwDr8oYQ

After everything was reinstalled I went to Cubase with the intention of connecting the nanoKontrol2 after Cubase was loaded. When the device was still absent I closed Cubase, connected the nanoKontrol2 and when Cubase9 then launched it was recognized and I could then set the settings as per the Korg instructions.

So all’s good. Not sure what part of the puzzle solved the issue. But all’s well now :slight_smile:

Russell