Nasty Bug:Where does WL8 decode files to during conversion?

Morning,

During a batch processor conversion of 24 FLAC files (24/192) to 16-44 - I noticed a nasty exit and series of locks using the Batch Processor.

While I was processing - I wanted to cancel the process due to a discovery on the MBIT+ plugin (my previous thread this morning) and when I tried to cancel - WL then kicked up a series of messages and I was finally able to limp my way out of the conversion. I then cleaned up any wavs created in my target folder.

When I returned to try this set of files again to retry them - I dragged the FLAC files onto the processors but this time WL reported that some were already decoded, some were “being” processed and in the end - instead of 24 wavs - I ended up with 9.

More bothersome was the situation in the attachment. When the processor finally finished (I have it set to remove files after processing)…this run left one file in the window - which could not be removed no matter what I tried. And then when I tried to remove it - I get the message you see in the graphic.

On another failed run of the same file set - WL removed ALL the files from list as processed and then when I tried to close the BP - this same message appears. The only way to shut down the BP was to hard kill it using Task Manager.

So questions:

  1. Where is WL storing previously decoded FLAC files (or is it?) How does it know that something has been decoded.
  2. What is up with the message in the attachment? Obviously there is some serious issues with cancelling a conversion that leaves the processor in some strange state - thinking it’s still going?

Appreciate an update.

VP
8-20-2013 9-27-07 AM.png

The decoded files are stored there:
2013-08-20_18-25-17.png
You can simply erase the content of this folder.

I think you have come on a bug related to the caching of decoded files when a batch process is interrupted. I will have to try reproducing this case.

PG,

Thanks for the quick look-see. Will investigate on this end and report back.

VP

PG,

OK - I emptied that cache folder and was able to reprocess almost all of the 24 files. However now - WL seems to bypass at least 5 files with no decoding and no processing and leaves them in the processor window. And again - any attempt to remove them gives that message saying the batch processor is still processing.

The only workaround that actually works is to NOT let Wl decoding the FLAC files by dropping them in the BP window. If I extract the wavs manually - and then just drop the wavs on the window - we get a perfect conversion run…each file is removed from the window as processed and when the processing is complete - I can close the processor with no messages saying anything is running.

So it seems there is a problem decompressing certain FLAC files and another problem with being able to actually stop the processor if something remains on the list due to perhaps an error encountered while decompressing the FLAC.

Cannot tell if WL does any actual error checking to ensure it’s has a valid FLAC file to work with - prior to starting the decompression routine.

For now - I will simply pre-decompress everything and just process the high res wavs into target lower res files.

Cheers!

VP

VP

How long are your FLAC files, and in what bit format (so that I try to reproduce the issue).

The group that caused the issue were 24/88.2 FLAC files. They were all Elvis songs - so no more than 2 minute each :slight_smile:

Odd that WL converted most of them but bypassed about a half dozen for some reason. None of the tracks exhibited any FLAC errors when I manually decompressed them using the standard FLAC tools.

VP

Do you have the multicore option enabled in the batch processor?

Yes - ALL cores are on.

VP

I have found the problem. It happens when all these conditions are met:

  • decoding (flac, mp3, etc.)
  • multicore
  • Auto remove converted files

If any of these condition is not met, the problem does not happen.
This will be fixed in 8.0.3.

You rock - as usual! Thank you.

VP