Natural humanization in dorico 5?

Hello,

I’m wondering if there is an efficient way to humanize the MIDI files in Dorico 5 to get a more realistic and natural performance from the playback ?
As for now, my instrument (and especially my piano) feels a little too robotic since it’s basically perfectly aligned with every grid. I’m aware that I can always manually shift every note a little but that also seems like a very time consuming task.
So is there some good feature in dorico 5 to get this effect ?

Thanks in advance,
Cheers!

Have a look under Playback Options-> Timing.

image

You can also read about dynamics humanisation in the reference manual as well.

It’s never going to sound like a person, but this is better than nothing. And you may be unsatisfied since it is set at 30% on by default already.

The best answer is to go out to Cubase. Dorico is not a DAW, despite the massed thronging crowds crying out for it to be.

2 Likes

I’m doubtful jitter humanization does that much - it’s too easy a solution and humans don’t work that way. Basically it’s just adding temporal noise and humans are really good at filtering noise. Cognitively what listeners hear is not random error but … I don’t have a word but call it intentional error. Temporally that means rubato.

The team is working on ‘academic research on humanization’, would be interesting to see what’s been done, but this very likely means algorithmic humanization based on psychoacoustic observations. So far we have the “lines toward a peak tend to increase in intensity”, so a volume error (error here meaning humanization, it’s really a systemic error).

I’m thinking we’ll see a temporal humanization too, which is probably along the lines of ‘subtle rubato between phrases, more so with ‘sweeping’ phrases’ if Dorico has a good detection method.

1 Like

Dorico 5 also introduced pitch contour emphasis, which you could consider a subtle but powerful “dynamic humanisation”:

2 Likes

Question about this setting (Note start position), so I tried to change it to 100%, and then observe the MIDI data in the “played durations” screen where you can see the played duration of each MIDI file during playback.
However, when changed this setting to 100%, the note start position of the midi data seems to be unchanged? It still looks like the notes is starting to play at the exact start of each grid ?
Is it supposed to look unchanged or is it not working properly ?

Very interesting!
So If I have understood it correctly;
“Scale effect by” does increase/decrease the total range of this effect ? In other words, having a lower value here decreases the total effect of all these settings, and vice versa?

“Maximum change to written dynamics” determines the allowed maximum random change of each note ? So a high value here can make the randomized dynamic be stronger on each note, and vice versa ?

And lastly, “humanize written dynamic by” does increase/decrease the frequency of the randomized effects ? So a higher value lets the notes be randomized more often, vice versa?

Just want to make sure that I’m understanding the settings correctly so that I know how I can play around with them.

Thanks!

Does humanization change the playback notation in the key editor for a one-time-fits-all humanization, or does the playback notation stay the same and the computer apply the humanization on the fly each time?

1 Like

I found this thread while searching for answers on this myself, and have since done a little digging.

It looks to me that Humanizing Note Start Positions was working correctly in Dorico 4, but is not working in Dorico 5.

I’ve created two simple identical projects, one in Dorico 4 and one in Dorico 5. For both projects, under Playback Options > Timing > Note Start Positions I’ve set Humanize the start positions of notes by to 100%.

As you can see in my image below, the Dorico 4 project is clearly displaying humanized note start positions in the Key Editor while the Dorico 5 project is not.

To test whether this was just a display error in the Key Editor or an actual playback error, I exported the midi files (here and here), opened them in Cubase 12, and found the same results, which you can also see in the image below (you might need to click on it to see at full resolution; I’ve pasted the reported start times for each midi note).

The alternative explanation is that I’ve missed something or changed another setting. I’ve attached my projects above if anyone would like to dig around. Thank you. :slight_smile:

2 Likes

I noticed that too! (wondering if this is somehow related to the newly introduced functionality of offsetting playing techniques)

Hi Lillie,

Now although the pitch contour for dynamic works well, the timing humanization do not work normally. I found this to be an issue, probably a bug?

Thanks for reporting this, @RRComposer. I can confirm the problem, and we’ll make sure this gets fixed in the next update.

2 Likes

It’s been nearly four months since the last post about this. Is there a fix coming?

Thank you, Daniel

Next update (5.1) is supposed to be coming in a month or so. Hope it answers your question.

Very glad to hear, thank you. Felt like I was waiting for an update that would never come. I will continue to wait, more patiently.