Navigating Dorico Slow

Hi everyone,

I’ve done some searching on this forum and haven’t found a solution to my problem yet:

Navigating around Dorico is very, very frustrating at the moment. Things like switching between Write and Engrave take 10-15 seconds. Right-clicking and then scrolling between different options (eg between Filter and Dynamics) is the same. Ditto when switching between Safari and Dorico. Even just selecting notes can take this time.

This isn’t always happening, but it’s a large percentage of the time - enough to ruin my flow and make me want to throw my computer in the pool. Not sure if this is relevant but I’ve checked Activity Monitor: When idle, “VST Audio Engine” is 69% (CPU), 6.7GB (Memory) and 71 (Energy).

I’ve tried the MIDI loop advice and also turning MIDI Thru off. No deal. I’ve tried adjusting the audio latency. No deal. I’ve tried creating a smaller layout with just two instruments. No deal. The only thing that is making me feel better is my bottle of Glen Grant 10yr Old.

This doesn’t happen with my old software and I’m aware that Dorico’s engine works completely differently, but can anyone help me?


I’m running Catalina 10.5
2.9Ghz Quad-core i7
16gb RAM
External Thunderbolt 3 screen
Apogee Duet 2
YAMAHA S90ES (driver is up to date)

Sorry to hear you’re running into this problem, Daniel. The good news is that there will definitely be a specific cause for the problem, and once we find it, we should be able to restore good performance. Could you please choose Help > Create Diagnostic Report and attach the resulting zip file? That will allow us to get a look at some log files and settings that will hopefully point us in the right direction.

Thanks for the quick response Daniel.

I’ve attached the Diagnostic Report. I didn’t know if the project had to be in a certain state and so I just left it on the Full Score layout in Write Mode.

Dorico (1.54 MB)

Thanks very much for sending the diagnostics. In general I can’t see any particular smoking gun as yet. One thing I notice is that you’re still running Dorico 3.5.0, and an update to Dorico 3.5.10 with a number of fixes and improvements is available, so I would recommend you download and install that in the first instance. You can download it here.

The other thing is that the VST audio engine crashed recently due to a fault in the EW Play plug-in, so you might want to check that you have the most recent version of Play installed as well.

It doesn’t appear that you have a MIDI feedback loop going, because you seem to have disabled all but one of the input ports on the SE90, but perhaps you can just check again to make sure there are no expected input devices showing up.

Are you working with lots of windows onto the same project open, or lots of tabs open inside the same window? If so, you might try closing all windows but one, and closing all tabs but the one you’re currently working on, and see if that helps.

Just one tab and window open.

I’ve downloaded this and the Play update (which there was). I think it is a little better!? I’ve got to open up that bottle of Glen Grant now (it’s 9pm in Australia) but I will have a good play with it tomorrow and let you know how I go.

Thanks very much again.

Is this a 2016 MacBook Pro?

If that hasn’t helped sufficiently: The VST activity seems quite high for idling. Test it without any third-party VSTs.

So, I updated both Dorico and Play and I’ve seen a substantial improvement. Well, enough that I’m not going to drink every night anymore.

Benwiggy, it’s a late 2017 MacBook Pro. With the updates I mentioned, the CPU goes down to 50%.

Cheers everyone

What buffer size are you using? Try increasing it. Very small buffer sizes require lot of extra CPU

Sorry Paul, I’m not at my computer currently. I’m pretty sure it’s around 512 - it’s just enough for a noticeable delay when pressing notes.

There’s another thing that might show what’s happening with the high audio engine CPU. Open Activity Monitor and click on the little cog-wheel at the top of the window, a pop-up menu appears from where you choosse ‘Spindump’.
Save the output of the Spindump window, zip it up and attach here.

Hi Paul,

I’ve attached the spindump for you

Daniel (282 KB)

We’re still digging into that, but one thing that we can see is that most of the time is spent inside HSSE. HSSE is also taking up quite a lot of RAM. Is this a project with lots of instruments? Try running Play > Playback Template and choose the HSSE/HSO Pro template. This will reload all the instruments and remove any gaps (which can happen if you add and remove instruments and import/merge other projects).

Do you get the same high CPU if you just create a new score with just a piano instrument?

Another thing to try is to open the HSSE window and in the Options tab try changing the option Performance > Multi-Core (eg try 2 cores)

There’s also an update available for HSSE - 3.4 is the current one. I think you can download that using the Steinberg Download Assistant.

Hi Paul,

Thanks for the info. I’ve updated HSSE and I’ve reloaded the playback template as you suggested. I also tried the multi-core trick which didn’t change the CPU either. For all of these, the CPU was sitting at approx 50%.

The project I use is quite large, it uses 4.5-5gb RAM . I tried creating a solo piano project and the CPU went down to about 15%.

I’ve now looked at the log in a bit more detail and I can see a couple of things that could indicate a problem. One is that HSSE seems to be spending a while processing mod wheel messages. So try disconnecting your MIDI keyboard to see if that makes any difference. If it does then it often means you have some dust in the controls, which you can often fix by spraying a can of compressed air.

Also EastWest Play seems to be occupying a large fraction of that CPU usage. If there is a problem with the mod wheel then this may affect Play too.

Hi Paul,

Still no luck. I tried unplugging the MIDI and the CPU still sits at approx 50%.

Not sure if this is useful but I’ve attached spindump and diagnostics for the project both with and without MIDI.

diagnosticsspindump without (1.38 MB)
diagnosticsspindump with (1.37 MB)

Thanks for providing the files - I’ll have to wait until Ulf is back in the office to see if he knows what’s happening here.

Ulf and someone from the HALion team have had a look at these, and unfortunately we can’t find any specific causes of this high CPU usage. We know that there is some necessary CPU overhead as the number of plugins increases, but we don’t usually see this much. However, here’s a couple of last things to try:

  • Ensure you are running on main power if you have a laptop. When laptops are running on battery they reduce the CPU frequency and so you will see higher CPU usage because at a lower speed it’s taking longer to do the same work
  • Also check any power saving settings that may be reducing the CPU usage, check your machine for overheating (which will also slow down the CPU)
  • If you have a macbook, there are some quirks where I think it can overheat if you plugin the power supply into the wrong side, so try switching it
  • Apply the default playback template to your project to remove any unused plugins
  • Hide any plugin windows, as they take extra CPU time to keep them updated.

I’ve tried these little tricks and I’ve got the CPU down to about 40-45. It’s not perfect but it’s better than it was, and it will have to do, I guess.

Just out of curiosity, if I bought a top-of-the-line Mac Mini, with every upgrade it could have, and I had a 20-30 VST instrument project: is there an approximate CPU % that you would expect I should be seeing? Should it definitely be running slower than a solo piano, or with the best Mac, not be too different?

I think it’s entirely dependent on how resource-intensive those virtual instruments are. If you’re running 20-30 separate instances of a plug-in, then that will almost certainly be consuming a lot of resources, whereas if you are using a multi-timbral virtual instrument (like e.g. HSSE itself) then 20-30 sounds should only require two instances (assuming 16 channels per instance), and a top-of-the-line computer should run two instances of HSSE or Kontakt etc. comfortably.