Need a little help setting up a nanoKONTROL2

Hey all. So, I just bought a Korg nanoKontrol. Hooked it up, and it installed auto. It is currently listed in my Win7 device mgr.

Cubase sees it, and if I move a nK2 fader or knob, I actually see MIDI activity on the Cubase MIDI ch it’s hooked up to. The fader doesn’t move - but that’s ok. That’s not what I am going to use it for.

How I am planning on using it, is with Kontakt, loaded inside of Cubase. Currently, I don’t see where Kontakt sees the nK2, if it does. I would like to be able to control some of Kontakt’s parameters with the nK2, but currently seem unable to do that. I have been told that this would be possible. Was hoping someone might have an idea of how I should go about this.

Thanks in advance.

Easiest way is to assign your nanoKontrols to the VST Quick Controls then assign the parameters in Kontakt you want to control to the VST Quick Controls. You could also use the Track Quick Controls but VST QCs are more directly intended to control VSTi parameters.

load something into Kontakt (version 5 here)
On the left hand side of Kontakt select Auto - Midiautomation.
Drag one of the midi ccs onto a dial. Make sure it’s a number that you have on your Nano and make sure it isn’t one of the CCs used by quick or track controls.
Should work.
Make sure in the inspector that your Kontakt is set to all midi inputs.
Neil

Thanks guys!

Right - know how to do that…

And here is where I am a tad lost. If I go to QC and select the nK2 as in & out, I see that the 8 controllers are all addigned to address 7. If I don’t change anything, and assign CC7 in Kontakt’s Midiautomation tab to a Kontakt knob, fader # 8 does indeed control that Kontakt knob, but it also controls Cubase’s Instrument track. Which of course, I don’t want. So, if I assign CC8 in Kontakt’s Midiautomation tab to a Kontakt knob, and in the QC change nK2 controller 7 to an address of 8, that controller (fader 7) does not control that Kontakt knob.

Hopefully that is not too confusing… what am I missing here?

Here’s hoping this isn’t too long (and I’m not at my music rig at the moment)
There is another post or 2 in the forum about nanocontrol - I was a part of it. within there I listed the default Cubase QC’s & TQC’s.
Not to be confused with midi. Hope this is the right terminology - they’re for host automation, which has nothing to do with midi. In fact any cc codes in the QC’s & TQC’s will override attempts to use that CC as a midi control.
My set up - a midi keyboard into a Kenton Control Freak midi controller, to midi in on the soundcard.
As well as that I have a Nano - version 1 as a USB input.
It may be worth in the QC & TQC setting the midi inputs to not connected, so they don’t override the midi functionality of the Nano while you’re setting up. I always have my midi outputs set to not connected anyway, but that may be ignorance.
Now, any midi CC controlled by the Nano should work in Kontakt. However, today I found that a few didn’t but try, for instance CC16.

Now, back to the QC’s & TQC’s -
This may sound really stupid, but I went through every VST I’ve got (GPO, Camelspace etc) and listed all the midi CC’s that they use. Once I’d done that I changed the QC’s & TQC’s to 16 codes that weren’t used anywhere else (barking mad, I know).
Then I set the inputs to all midi inputs. I can use either my Kenton or Nano now for Midi and for host automation.
Suggest you get the midi bit working first so you know your midi is set up okay.
Hope that helps.

2 more tips:

  1. have you downloaded the Nano software - the Korg Control editor? vital for editing your Nano scenes.
  2. My version 1 Nano sometimes throws a wobbler and doesn’t work. So before I go into Cubase I always load the Korg editor software up. If it shows a non-communicating message, I unplug the nano and plug it back in, otherwise it won’t work in Cubase - but that could just be a problem with my rig.
    Let us know how you get on.
    Neil

Cool - thanks for the info!

I have a project I need to get to, so I have to put this off for a bit. I’ll come back if any have any more trouble when I try this again.

Cheers.

Hi - I am back to seeing if I can get this set up.

Taking a look at this, and I have absolutely no idea where to begin to get this working. I have read both above posts 2x, but have no clue as to where to point my mouse.

If anyone can give me some pointers, I would appreciate it. Thanks!

Hi Jeff,
while both methods described above are good, generally, I wouldn’t actually recommend using VST Quick Controls with Kontakt 5 (it works, but you can’t see what each page of eight knobs in the VST Instrument rack are actually controlling… they don’t have useful names, so you’d have no way of substituting a knob for another while knowing what you were doing! :wink: Same problem with Track Quick Controls… no names for the slots). On the other hand, VST Quick Controls are, generally, a great thing, and very useful… just not for Kontakt :wink:.
So, that takes us back to the method that you already know, using the Auto pane on the left of Kontakt itself, or, more simply, by using right-click on a Kontakt parameter, and MIDI Learn.
Just be aware of one general rule (mentioned by Neil B)…

this is because any incoming MIDI that is used by Quick Controls (in Device Setup) is “swallowed up” and so won’t be seen at the MIDI Input of a MIDI/Instrument track in the Project window.
So, to avoid confusion for the time being (small steps at a time :wink: ), don’t have Nano used as Input to either VST Quick Controls or Track Quick Controls when wanting to control Kontakt from the NanoKontrol.

Back in the Project window, your MIDI/Instrument track for Kontakt will of course need to have the Nano as its MIDI input, or more probably, as part of its MIDI input (presumably you’ll be wanting your external MIDI keyboard also! :wink: )… and, for that, you’ll need to use “All MIDI Inputs”, so you’ll need to set up “All MIDI Inputs” in Devices menu>Device Setup>MIDI>MIDI Port Setup accordingly… and I always advise to un-check anything you don’t really need there :wink: ).

Hi vic! :slight_smile:

Oooh - almost there.

Ok, so Cubase sees the Nano as an input when I create a MIDI track, and also in the Device Setup > MIDI Port Setup. And I can indeed control whatever Kontakt param I choose with the Nano, by dragging the appropriate CC from Kontakt’s MIDI auto tab. ok, great. BUT…

What I can’t seem to do is get rid of some assignments that seem to be there by default. For ex., Nano’s fader #2 - which is CC1 - controls Kontakt’s modwheel. If I assign CC1 to a Kontakt volume knob, Nano’s fader #2 will now control that knob, but it still also controls the modwheel. And there is NOTHING listed in Kontakt’s MIDI auto tab, and I am not sure how to get rid of that particular assignment.

Understandably, this is not really a Cubase thing, but before I hit NI’s forum, does anyone know how to do this?

Thanks again!

I’m fairly certain there is nothing you can do about that… CC#1 is hard-wired to the mod wheel. But , at least, some Kontakt instruments (that have the “Spanner” icon, meaning that you can edit them, will allow you to render the movement of the modwheel null (but it is on a per instrument basis, and you’d have to save as a new instrument, to make it permanent.
Kontakt does have an option in Global options (the “gearwheel” at the top), t as to the behavior of CC#7 and CC#10, but not CC#1, unfortunately.
There are also global scripts for filtering incoming controllers, but if you filter CC#1 you’ll also be preventing it from reaching that volume fader… catch 22! :stuck_out_tongue:
So, what you’ll have to do, eventually, is use the NanoKontrol Editor to change the value of fader #2 to some otherwise unused value. (“then you’ll be a man, my son” :stuck_out_tongue: )

Ok, that sounds like what I need to do.

So, umm, how do I do that? What is the NanoKontrol Editor?

–edit–

Did a googley

You mean this?:


Assuming yes, it lists the Nano, but it says it is “unconnected” - even tho it IS connected, and Cubase sees it. So when I change the CC for fader #2, nothing happens. :confused:

As Neil mentioned, you have to download it from Korg…
http://i.korg.com/SupportPage.aspx?productid=596 Open the tab for “Software” and download Kontrol Editor. Might as well download the pdf documents while you’re there, if you don’t already have them :wink:.

Ah, we posted @ the same time! :laughing:

You’re on PC, yes? Sorry I can’t help getting the software and the hardware to talk to one another. But it must be possible. Maybe you just have to reboot first, with the Nano online of course ?

Thanks.

Yes - Win7

If I start the Korg Ed. before Cubase, It sees the Nano as connected. If I start Cubase first, It doesn’t.

If I start the Korg Ed., then Cubase, then click on the Nano in the Korg Ed., I get an error that says " Failed To Open The MIDI port".

Now what? :laughing:

–edit–

Should I set the MIDI ports manually? If so, to what?
korg2.jpg

Hi Jeff
Sorry to be a bit late coming back to this one, but Vic has been saying things so much more eloquently than wot I would 'av :slight_smile:
My previous post suggests that this failed to open the midi port is one of my bugbears too. You’re not doing anything wrong, but I have yet to find a solution.
You just have to ensure it’s running/communicating via the editor first and then it should be fine when you go into Cubase. As I said, sometimes you just have to unplug it and then plug it back in again (on the Nano, not the pc end)
It’s on my endless to-do list to find a solution (hopefully) to this, but once it’s working, it’s a great tool.
Hope you get it sorted
Neil

Oh, and in response to you “Now what?”
I suppose that when you go into the Korg Editor, it is a direct connection via windows.
If you try to go into the editor when Cubase is running, I’d have to assume that the editor can’t see it, as it’s virtually re-routed through Cubase, and Cubase has got a hold of it.
Perhaps a poor choice of words (Vic IS more eloquent) but I think you get my meaning.
Key thing then is planning - set up your scenes in the editor with the midi CC’s you want before going into Cubase/Knotakt.
Frustrating eh?
Neil

I am presuming that this will be the same on PC as it is on Mac (btw, my NanoKontrol is a V1, but basically the same, I think :wink: ).
So, yes, run the Nano Editor while the NanoKontrol isn’t being used by anything else (e.g. Cubase :wink: ), and make your settings. Not actually necessary, but highly recommended… Save as a new configuration (so you can reload it, if necessary). Now, you can quit the Nano Editor… you won’t need to run it again, unless you wish to make further changes.

I’m on a V1 too.
There’s is something in the depths of my ageing mind that says I saw a solution to this for V2’s. Have a Google around Jeff and you may find something. I seem to remember it requiring messing about with the registry or something similar that is alien to me, so I never tried it.
Neil

Hey Neil :slight_smile:

So, I am not understanding…

If I start the Korg Ed., and make changes to fader #2, then start Cubase… do I save a scene? Then what - do I leave the Korg Ed. open, or close it?