Need help connecting external hardware compressor to UR28M

Hi everybody,

I’m on Cubase 10 Pro (10.0.60) and have a UR28M interface (latest drivers installed) on Windows 10. I would like to run my vocals through an external hardware compressor (Klark Teknik 76). I am able to create the external effect through Audio Connections (F4) and select it as either an FX send or an insert in Cubase. But I can’t get the routing right, because the compressor is not receiving any input at all (and obviously not giving any output either).

Here’s what I’ve done routing-wise:

  • Microphone XLR goes into UR28M Analog In 1
  • Send Bus 1 (mono) to compressor IN has Device Port UR28M Mix 2 L
  • Return Bus 1 (mono) from compressor OUT has Device Port UR28M Analog In 3

Screenprints: https://www.dropbox.com/s/k656zd39qpc3mpi/Cubase%20Audio%20Connections.jpg?dl=0

Found several threads on this, for example: https://www.steinberg.net/forums/viewtopic.php?t=138296
But somehow I can’t seem to fix it. Hope you can help me out here!

You need to switch to independent setting for the outputs, not alternate. also uncheck link option (in UR28M hardware settings). Then you need to assign each output to corresponding mix bus, so select A output then choose mix 1, then select B and choose mix 2 , select output C and choose mix3. Finally, for the hardware output pair of connectors you plan to use to feed outboard gear, you need to raise the UR28M big volume knob all the way to zero, ie, let’s assume you will choose outputs 3 L&R to feed your outboard, so you switch to C output, assign to mix 3 and raise it’s level all the way to zero. This level will now remain default to output C, no matter if you switch to other output (A or B) and move the knob. Just be careful when switching to another output to monitor, stop playback, choose for ex output A, lower the knob all way to zero then restart playback and turn your volume knob slowly. Hope this makes it clear