Need help on SX 2 problem

My SX 2 has run flawlessly for 7 years now. But suddenly this week it won’t open. It goes through the loading list until it comes to Global then it disappears. I thought I could just reload the program with my original 2.01 CD, but when I reboot it requires going to the website for online updates. When I go to the Steinberg page I get a 404 message, “Page not available.” I’m not sure reloading the program will solve the problem, but without that page, I can’t even do that. Has anyone had this problem and is there anything I can do to troubleshoot this problem that you know of? Thank you.

Cubase SX 2, Windows XP, Firepod interface.

I guess the website is not available anymore, because the SX 2 support was discontinued. You can still download older versions here: ftp://ftp.steinberg.net/Download/.
But it seems SX 2 isn’t also available there. Couldn’t you reset your windows system to a restore point, before the error appears?

Aloha H, and welcome to the board. E’ Komo Mai’!

+1 I agree.
Something must have changed in yer system because it was working so well for so long.
A restore might be the solution.

Did you do a ‘Carbon Copy Cloner’ or ‘SuperDuper’ type ‘image’ back-up?
If so, then back-up is quick and easy. :slight_smile:
And if not, you probably will from now on. :frowning:

BTW
It is very kool and I am very proud of you still using SX2 for so long.
SX1 gave me probs but SX2 was stable and usable.

And then came SX3 (which I still have working on an old G4 laptop)
which was at the time pretty awesome and worked well enough
to use live on stage as well as in the studio.

Harry I hope you get your problem fixed and soon. Good Luck!

{’-’}

Thanks. I will try the restore. Evidently there isn’t any other solution. Feel like I’m stuck in a time capsule. I just feel that when you sell a product you should leave the support for that product on the website. I love direct X and can maneuver freely around SX2 to do anything I want and quickly. Work with SX3 in another studio and several different Pro Tools systems in some other studios. But for me there’s nothing like Cubase SX2. I’m in the middle of several projects right now and am losing money as long as I’m down. Thanks again.

Restore didn’t work. Loaded in LE to finish the projects I’m on. Don’t know what to try next.

Just seems to me that if I had bought a Dodge truck in 2006 and had a problem with it, I could take it to the dealer and he wouldn’t be putting a time limit on the service. This is patently unfair of Steinberg.

You can’t compare car’s with Software. These are two different worlds. I understand, that you are not happy with the situation, but to keep support for old versions alive, means a lot of effort and costs. Every software company handels like this. Okay that doesn’t help you.
Don’t you have the SX 2 Installation CD’s?

Yes I have the installation CDs but after I load in Cubase it asks for a reboot. Then when I reboot it asks to go to a Steinberg website to check for updates. It goes to a website, says it no longer exists and the Cubase load won’t resume from that point. Without that website, there’s no way to continue.

But it must be possible to install without checking for updates somehow. Isn’t there a cancel button or a checkbox when it checks for updates. Can you unplug your Network cable while installing? To simulate a PC without internet Connection.

I keep my work computer off line most of the time. But I’ll try your suggestion and remove the Pantech before the reboot. Thanks.

Got it to load finally. But still get the same problem. Loads as far as Global Settings then disappears. So there’s something in the computer that doesn’t jive. Sound Forge and LE open flawlessly; just not Cubase. Thanks again for your help and suggestions. Time to go shopping I guess.

Sorry to hear this.

Finally you can try the latest SX 2 Version from the steinberg ftp server. I found out that also the older versions are available.

Get the latest PC version here:

ftp://ftp.steinberg.net/Archives/Cubase_SX_2/2.2.0.39/Pc/