Need help setting up multitrack recording in Wavelab Pro

Hello,

Quickly introducing, as I am new on these forums since today.
Recently I acquired Wavelab Pro 10 to perform multitrack recordings that I intent to record via loopback channels in my soundcard as 4 stereo channels… If I do stereo recordings it works. however if I want to record the multiple tracks together I get messages from Wavelab that I do not know how to resolve.

I set up as …
Playback:
Main playback bus: L front Ch 1 + R Front Ch 2

Recording:
Main Recording Bus -> L Ch 9 + R Ch 10
Bus 2 -> L Ch 11 + R Ch 12
Bus 3 -> L Ch 13 + R Ch 14
Bus 4 -> L Ch 15 + R Ch 16

[…]

Assign a bus to 2 different audio montage tracks, and record both tracks.

New > Audio Montage -> Mode: Multichannel (Free Configuration) ; Channels: 8 channels ; Sample rate 44 100 Hz
Created two different tracks, record enable both tracks, then hit record.

What does the dialog mean that appear first?:

The active audio device connections do not allow to play all audio channels.
If you continue, one or more audio channels will be muted.
[Stop] [Open AudioConnections] [Continue]

Upon click on Continue, the multiple tracks start recording.

If you select 8 channels for the montage, your audio device must be set to play 8 channels.
I think you should rather set 2 channels for the montage output. That does not prevent you from recording 2 stereo tracks at the same time.

Yes that is exactly how I do it. More than one stereo input bus so I can select the appropriate channel input in the Montage tracks + 1x stereo output bus for the monitoring out of Wavelab.
The dialog I get each time when I enable input monitoring pre-recording, or after recording, or when changing monitoring settings on the tracks e.g. on/off. If I click on Continue it moves everything forward in a normal way.
You can set a checkmark that Wavelab does no longer bug you with this message, but it’s only during the session you are in. If you restart Wavelab the bugging again starts :slight_smile: Maybe for the future a permanent checkmark to forever avoid this dialogbox?

But maybe more important to know is why this dialog appears each time. It may either have to do with the Audio Connections settings with 1 st pair for output and 8 st pair of input, or something else. My audio driver would not be the issue, since that is multiclient and runs stable always.

Ideas welcome :slight_smile:

The message you see, is to say that your audio tracks (mono or stereo) does not have the same number of audio channels as defined in the Audio Connections dialog.
Please show a screenshot of the record and playback Audio Connections dialog.

That’s it! Thanks for (literally) putting me on the right track. I was able to resolve now.

It was in the Audio Connections Playback settings after all. Dialog shows with out ch3-8 = unused and Dialog does not show with out ch3-8 having an active output.
I guess due to Recording busses consisting of 8 channels (even though 3-8 unused) still a Playback bus of also 8 channels is expected. Note I have always on all tracks set the output dispatch to topjust to playback channel 1+2.

For reference:



P.S. how do i on multiple tracks enable recording or monitoring for a group of tracks (as opposed to having to go through each track individually)?

how do i on multiple tracks enable recording or monitoring for a group of tracks (as opposed to having to go through each track individually

You have to arm recording for each one. Then press record on the transport, to start.

I’d like an overall “record-arm all tracks” feature :bulb:

Any case I tested somewhat with the Montage setups. Conclusion is that if you set up a 2track/stereo montage, that it does not matter if you in your playback bus have only L + R channels selected and leave 3-8 unused.
But, looking to above, I found out I had created a Montage as " Multichannel (freefrom). So it is logical that this Multichannel Montage looks also for the other 6 channels on top of only L+R.

I’d say problem fully solved! Thanks PG for the directions to the solution and this conclusion.

Happy now that I can start Wavelab from one or two Montage templates and it’s up and running now in no time.