Need help with External FX (Cubase and Saffire Pro 40)

Hey, so I’ve recently bought an outboard 2-channel compressor (stereo and 2-mono capability) and want to be able to use it as an insert plugin in Cubase (I have Cubase 7.0.6). I also have a Focusrite Saffire Pro 40 which uses the Saffire MixControl software. Prior to trying to use external fx, I’ve had no issues setting up Ins and Outs in both Cubase and the Saffire MixControl. However, trying to set up an external fx is giving me lots of troubles. Here’s what I’ve tried, let me know what I’m doing wrong here:

I set up Cubase’s VST connections (all 8 inputs, all 10 outputs appropriately) then I set up an External FX (one FX in stereo, and I assign inputs 5 and 6 as well as outputs 5 and 6 to left and right, respectively). This deactivates channels 5 and 6 on the inputs and outputs, which is fine because it’s now assigned to my External FX.

Then, in my Saffire MixControl, I assign DAW 5 to output 5 and DAW 6 to output 6 (I think this is how it’s supposed to be). Then when I put the newly created External FX insert on a stereo audio channel (let’s say a synth bass), I adjust the send gain so as not to send too much signal to the outboard compressor, and I leave the return gain at unity (0db).


Now, here is my trouble. When the compressor is in bypass (the hardware bypass switch), the synth bass audio signal is perfectly clean and unaltered, but when I unbypass the hardware, it becomes quite heavily distorted. I can see on the VU meters that both channels are peaking at about -10db to -5db on the input, so I turn the send gain on the insert effect on Cubase and this lowers the distortion level, but the signal becomes much to quiet, so I have to turn up the output gain on the hardware unit. This seems to relieve any unwanted distortion but introduces a heck of a lot of hiss (I’m assuming because the hardware output is so high now). Then at this point I try the hardware bypass switch and, the bass is perfectly clean and fine.

Anybody know what is going on? I don’t want this distortion in the one case, and I don’t want this hiss in the other case. How can I fix this?

*also, I have the Saffire MixControl sending outputs 5 and 6 at unity (0db) because there is no way to control the volume separately from the main monitor ouputs 1 &2. The gain on Inputs 5 & 6 on the Saffire Pro 40 are set to 0.

**the hardware compressor is a new Art Pro VLA II

Here’s what I’d try;


Are you using the control room? If so make sure the regular stereo output is disconnected.

Firstly, ONLY make connections in the VST connections in/out you need, so a stereo pair for your monitors and the in and out put for your compressor.

Then, generate at 1 k test tone or download a wav file form the net and drop it onto an audio track. Insert your compressor and then you can at least set up the gain properly.


It sounds like the Safire is doubling signals somewhere in its convoluted mixer software.

MC

Thanks for the reply.

I’m not using control room, it’s disabled. I’ve been testing with a sine wave which is constant in frequency (C2) and amplitude (-10dB), so I think that is doing the same thing as you have suggested.

I’ve pretty much narrowed it down to it being the Saffire MixControl and me not setting it up properly. Except that I’m doing what the stuff I’ve been reading and watching tells me to do… ughhhh :cry:

Also, why would setting up extra VST connections cause any problems? If it does cause problems, then wouldn’t it occur whether I was using all of the inputs and outputs or using none of them???

Anyways, I’m going to search the internet yet again for more info on how to set up the Saffire MixControl, one day I’ll figure this stuff out…

I just tried disconnecting all unused VST connections, so the only thing connected is my main monitors on outputs 1 and 2, and the External FX on 5/6 in/out. Still didn’t change anything.

Could it be the compressor even though it’s brand new?

to be honest, the focusrite control panel is one of the most convoluted things I ever had to deal with. I’ve been doing this professionally for a long time but had to give up on the control panel when trying to sort out a friend.

Sorry I can’t be of more help.

You can tell if the compressor is ok by just plugging straight in and out of it.

MC

Threshold all the way up and ratio all the way down should sound almost identical to bypass.

Yeah that’s where I start at, threshold all the way up and ratio all the way down, output gain at 0dB, longest attack, shortest release, but it still gets heavily distorted and is too quiet, then gets the hiss. At first I thought the Saffire MixControl was a no brainer and every interface should have controls like it does to allow for better headphone mixing while tracking and such, but with all this trouble just to get an external fx to work properly, it’s kind of loosing its glamour.

Thanks for the suggestions though Norbury. So I also have tried going straight through the compressor and it seems to work fine as it should, so it almost is certainly Cubase and Saffire MixControl just not being set up properly.

So I contacted Focusrite’s customer technical support and provided them with the screenshots that you see in this post. They said that everything is setup correctly and should work just fine. I’m going to take their word for it both because they seem to know what their talking about and because it seems to be setup correctly independently of what Focusrite seems to think.

Also, I’ve returned the Art Pro VLA II compressor to the store where I bought it from to get the vU meters recalibrated and for them to make sure the inputs and outputs are working properly. They have not yet finished looking at the device (some two weeks later). So I await it’s return so that I can look into the matter some more.

If you guys have any further comments or suggestions on how to fix this issue it would be great to hear from you, if you don’t have a clue that’s also fine. But I figured I’d just give you guys an overview of what has happened thus far.
Saffire MixControl ScreenShot.jpg
Cubase ScreenShots.jpg

Ok, so final update. I figured out the problem.

The original unit that I had bought and sent back to repair the VU meters and look at the inputs and outputs is still in the repair shop (for a full month) and they haven’t fixed it yet. So I finally convinced them to just give me a new unit (Art Pro VLA II) and be done with this mess. I brought the unit home, hooked it up exactly as I did with the last unit and there is no problems. Everything works just fine.

Long story short… they sold me a defective unit. I don’t think they want to admit to it, but there’s no doubt about it, and I’ve been telling them that it was defective from day one. Soooo… anywho, I’m glad that’s dealt with.

Thanks everyone for all your advice and help with the issue. I’ve actually learnt quite a bit in the process.

Cheers,
Kevano

They’re taking their sweet time with that repair then :astonished:.
Is that ART or the shop you bought it from?

It’s the shop that I bought it from. The service tech couldn’t fix it himself so he sent it out to another repair shop to get it fixed.