Need help with: Pre count behaviour / midi recording

Hello there.

I am currently facing an issue when recording audio where cubase is jumping back to the beginning of the bar when pre count is activated instead of recording from where the locator is positioned.
(1. 2. 1. 0)


When recording midi the same principle applies, with the difference that it also happens without precounting. The recording starts at the locator, but the midi event is created at the beginning of the bar. The midi event also snaps to some kind of full-bar grid, meaning;
if the midi recording ends it automatically fills the rest of the bar with the empty midi event.
(ends at bar 3 in the screenshot)

what’s going on here?

Any help is appreciated!


When pre-count is enabled, it always snaps to the bars.

The MIDI Part snaping to the bars sit can disable in the preferences.


I have found the midi setting.

The pre-count behaviour seems very odd to me though, as it negates the idea of a pre-count.
I naturally want and need to start recording at any point in the project, but if cubase is dictating the point of recording I will just turn pre-count off and set my locator to the beginning of the bar.
In both cases I have to deal with overlapping audio events.

Is there any way to circumvent this?


The pre-count has to be synced with the bars, it doesn’t make sense otherwise. It has to be synced musically. And I have never heard a human to recount something like 3-4-1-2-3-4.

The only workaround would be to disable pre-count and place the cursor X bars ahead manually. And use Punch In to drop in record at specific place.

Let’s say I want to record a guitar solo and there is a bit of space left before the next bar.
I want to start recording at the 3rd quarter note of the first bar. (1. 3. 1. 0 in cubase terms)
I need a pre-count to prepare me tempo wise, so I activate it.

What pre-count has to do:
Count me in for chosen length and measure for a certain amount of time before I start recording.

What it actually does:
Pretend that it’s musical because it can’t handle starting anywhere else besides the beginning of a bar

My AudioFile will be overwritten and I have to wait two beats to actually start playing, which extends my precount time from 4/4 to 6/4.

As a precount measure I can only use the project tempo or a custom bar (like let’s say 2/4).
So even if I choose 2/4 the pre-count will start at the beginning of the bar.
How is any of this musical?
Aside from the fact that it was possible in earlier cubase versions… :slightly_smiling_face:

In that sense I am counting 1234, 34, which I would say is a natural way for musicians to engage that situation. The important thing is the tempo, not the amount of beats!

This sounds like a good way to do it. Thanks!