Nektar LX-88 double notes

I’m going nuts trying to get rid of double notes from my Nektar Impact LX-88 USB keyboard. I have downloaded the integration pack and it appears in devices. But no matter what I do, it records double notes. I have even resorted to MIDI (unplugged the USB connection) with the same result. In the past, I got around this with other keyboards by switching from “All Midi Inputs” to “Keyboard name” as the input and problem solved. I haven’t used the keyboard for a while but I know I have used it in Cubase before without this problem. I prefer the USB connection because without it, you lose the transport function. I’m getting two signals from somewhere and I have ticked and unticked everything. If anyone has solved this problem, please post. I’m waiting to hear from necktartech. Thanks.
lx88-1.png
lx88-2.png

Hi,

Most common issue in this case is to using DirectMusic and Windows MIDI Drivers at once. But in your case, it seems the DirectMusic driver is not available for the Nectar. Or am I wrong?

What happens if you disable the Nektar as a Temote Device and also disable all MIDI Input ports but the Nektar?

Or midi thru is active in the preferences.

Solved. Nektar responded and told me how to reset the keyboard. Power up holding down Split and Layer. The Layer function was stuck on. Thanks all.

1 Like

Nice! This solved it for me too. Thank you!!