Nektar lx49 mk 1

Hi all

Working in 12 on an M1 Mac. I have tried to map my lx49 via remote but when choosing for instance start, when I press the corresponding key on the lx nothing happens. The keybed works as does the pitch and mod. Nektar have informed me the 49 mk1 is no longer supported so I was hoping to set it up via the new system. Any pointers would be much appreciated


The earlier versions of Cubase 12 were bad with my Impact LX88+. I was able to map the knobs, faders and transport controls (after several tries) but they didn’t work as planned. The first fader never worked. Fast forward to 12.0.50. All the knobs and faders map well now, but guess what? The Cubase map doesn’t recognize the transport controls! It still works, though, so go figure. I do have the Cubase LX49 drivers from Nektar installed. Also, Cubase separates both of the LX88+'s midi input now where, in the earlier version, they had them combined.

Interesting. I have an LX88+ installed and mapped via Nektar downloads. This works fine. I am as you are in the latest version of Cubase however it just won’t recognise any of the sliders, rotaries or transport. I am no expert on midi. The drivers for the mk 1 lx49 do not play with M1 according to Nektar support bit I should be able to map it as a generic device. Can’t help bit think I am missing something really basic…