“New Audio Drivers Found” on every open

Hello,

I’m wondering if anyone has a way to stop Nuendo (and Cubase) from asking about “new audio drivers” on each open? I’m running Nuendo on an iMac Pro with Monterey 12.3.1 and using a RME UFX+ and a Thunderbolt 3 hub (no, the RME is not plugged in to the hub). Something about having the hub and the UFX plugged in via Thunderbolt causes Nuendo/Cubase to ask this every time.

Logic, Digital Performer, and Pro Tools do not have this issue of resetting the audio device each time. It’s only Steinberg products.

I’ve done the whole “deleted preferences”; reinstalled software and drivers; changed cables/ports; etc.

Thank you for the help.

Is it every time you open Nuendo or is it the first time after booting the computer?

Hi Mattias,

Thank you for the reply. It happens after the first time booting. I always make sure to turn on the RME before I turn on the computer.

Weird.

Even though this pop-up window is annoying, the bigger issue is the new detection of drivers resets my VST System Link and MIDI timecode ports. So I need to remap those each time I open Nuendo.

This happens on every Mac computer I have, btw. I’ve reinstalled the OS and all software from scratch on one just to see if it made a difference.

Did that happen on Nuendo 11? Seems like a prefs problem (but maybe not if you can shut down N12 and retart it without the problem until reboot) or the Audio Interface seems different to Nuendo on reboot. I don’t see this with the UFX+ on Windows, but I’m using USB as TB started behaving badly a while back.

Only thing I can think of then is trying to find maybe a file that isn’t properly written to, like a preference. So if the file that contains the studio setup and audio devices isn’t properly stored then your changes of course aren’t stored and Nuendo thinks there’s a new device.

Even though I’m on a Mac fairly regularly I’m not an OSX wizard so not sure what to check. Read/write permissions of said files or folders? Account type?

Might be worth looking into.

Hi, yes—this happens with N11 (and all Cubase/Nuendo versions).

My main rig is a Windows 11 computer and I do not have this issue with the UFX+. It’s something to do with macOS, the RME, and a Thunderbolt hub. If I remove the hub, Nuendo doesn’t ask about the drivers since the RME is the only audio device detected. Unfortunately, I need the hub since iMac Pros are limited to a small amount of Thunderbolt and USB ports.

Thank you, Mattias. I’ve tried resetting the permissions in the past but I’ll take another shot at it.

And you’ve tried daisy-chaining the hub off of the RME (if possible)?

I haven’t. The UFX only has a single Thunderbolt port. I’ve tried the opposite, though: connecting the UFX to the hub (only to test). No luck.

The UFX+ has an USB 3 port, which I’ve tested, and I do not have the driver issue. However, I purchased the UFX+ because of the Thunderbolt connection. If I can’t get this issue fixed I’ll probably just use the UFX with the USB.

Thanks again.

Question: Is that STD HDMI second monitor off, and then turns on, when you get this driver message? Dopes it sleep and wake on its own?

I get that sometimes if my HDMI monitor is hooked up but asleep. The next time I open Nuendo and that monitor is awake, it shows me the driver choice pop up window when starting.

I’m unsure if the HDMI affects this. It’s connected to the Thunderbolt hub via Mini DisplayPort to HDMI so that I can run a TV to host video playback. I don’t ever have the TV go to asleep or anything.

Before moving to Windows, my main rig was a 2019 Mac Pro using Cubase and a CalDigit Thunderbolt hub (without any displays connected) and I was still having this same “new driver detected” issue. This lead me to believe the problem lies between Cubase/Nuendo, the UFX+, and a Thunderbolt hub.

1 Like

Try by process of elimination. Leave only one of those drivers available (well, built in plus the aggregate) and nothing else.

Reboot and see what happens. Then add one device at a time, reboot, and see what happens. You’ll eventually find the culprit.

Hook up your RME next.

Then lastly the Thunderfart hub, BUT only the hub, and begin attaching stuff to it one at a time, again rebooting each time to see if / when the message happens.

I have this same issue and no HDMI monitors (screens also don’t have audio) connected. I do however have a OWC TB2 dock attached and this has an audio output. But if I disconnect that unit my setup won’t work… so I can’t really test it…
Is there a way in MacOS to hard disable/remove audio outputs from these types of devices? So that I only get whatever I want every time…
update: I’ve answered my own question: How to delete an audio device on Mac, easy tutorial (Greatdy) - YouTube
Perhaps this helps others.

1 Like

This happens on my machine as well. Mac mini 2018 with RME UFX+ via Thunderbolt on N11.
I don’t really feel like deleting kexts from my mac.
I take it as a small reminder how buggy software can be. If my computer really feels like nagging me it follows this with an eLicenser miscommunication. :smile:

Yeah, I’ve tried all that. (Thank you, though). I’m 110% sure it’s a Steinberg issue. But, like usual, we’ll never see a fix.

A matter of fact, I contacted Steinberg Support about this issue and they stopped replying to my emails once things got a bit more complicated than new-user issues.

1 Like

Same for me, first time opening Cubase after booting.
CalDigit Thunderbolt 3 hub. Mac Pro. Cubase 12.0.30.