New Halion Sonic 7 Player edit screen to big for 15 inch laptop screen

I saw the advert for Colors and downloaded it. Halion Sonic 7 was recommended on my downloads so I installed that. However the new Halion Sonic 7 player while in the edit tab does not fit on my laptop screen once a sound is loaded from Verve, Amped Electra and Colors. The keyboard and some of the quick controls are out of sight. Verve and Amped Electra were fine in SE3 but not now. It doesn’t matter much if I change the HiDPI settings. HiDPI off is slightly better. I’ve had issues with third party players and scaling and really hope this won’t be an ongoing problem within Cubase. Also it may be coincidental, but I previously could play the sound from Cubase straight from either my laptop soundcard or interface as I had the sample rate set the same. However since making the update it won’t play without distorting through the laptop soundcard. I’ve no similar problem re sound in Ableton Lite as I just tested it.
Is there a way get back to Halion Sonic Se 3 as the default player and getting rid of Halion 7. Or is there likely to be an further update which might solve this problem. I’m on Windows 10 and Artist 12 latest version.

Screen resolution? Scaling?

Hi my screen scaling is 125% (recommended). The screen resolution is 1920 x 1080 (recommended)

I just had a look on my system: and indeed … (Simulating your settings on a 22 Inch screen)
To uninstall Halion 7 go there:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Steinberg HALion Sonic
There you’ll find an uninstall shortcut.
To install HALion Sonic 3, use the Steinberg Download Assistant


Thanks I will try that

Is a double routing possible? That will add 3dB.

Then you can try to scale inside Cubase?

Thanks I’m back with Halion 3 SE. However there I’ve learned something . In Halion 3 SE the scaling is just the same with my screen settings. I suppose it’s only when I got Colors that I became aware of it, as I was actively using the edit screen, because the sounds are selected from there rather than by loading a program. My screen looked nothing like Doms looked on YouTube :slight_smile:

I have borrowed an external monitor to try it. The screens then can be set to 100% from the laptop screen. The screen display is fine for Halion on the larger monitor.
However I always use the laptop whenever I can set up for recording. Smaller screen resolutions set from within Cubase or from the laptops settings are too small. I will just have to work round it. I can have the load tab open and toggle button between the editor and player. It’s helpful to know as its probably not worth me getting any more Halion Instruments with my current set up.

The sound problem seems to be related to the buffer size on my laptop. I’ve not had to change it before when using Cubase. If I tweak with it I can it sounding better but not perfect. I was able previously, to listen to tunes from Cubase on the laptop speakers without an interface when I needed, but always have an interface connected for recording and serious listening. Just a convenience for me and useful for reminding me of tunes I’m working on. It’s only Cubase that’s doing this. Ableton Lite for instance is fine. I’m thinking though it’s maybe more of a laptop issue than Cubase. Thanks for your help.

Regarding the sound problem. It was a laptop issue with the mic settings. “Allow apps to access your microphone” was on. The problem stopped by disabling this. As a lot of people on the forum point out, it tends to be computer issues that cause a lot of the problems. I find though, that checking in and getting some help and feedback when issues arise helpful. Thanks

1 Like

Small window user.

So Verve edit page still unscalable in Halion Sonic 7? I got cut off like this:

I stay in Sonic 7. Someone kindly drop a word when it works. Thanks.

Set the scaling on Windows to 100%.

100% a charm!

125% still got cut off. I guess my screen is real small… At 100% every word is tiny…

Good enough. Workable. Thanks!!