New installation, old projects: plugins missing even if they are installed


I’ve done several researches and found no proper solutions to my problem.
I’ve bought a new pc and had to reinstall cubase + all my plugins, win10 pro.
Everything’s fine except for two plugins (for the moment, maybe more, I still haven’t checked all my old projects): SonEQFree by Sonimus and kHs Gain by Kilohearts. Both are free.
SonEQFree was named SonEQFree.vst3 and SonEQFree in my vst manager. After the reinstallation, the plugin was updated and is now named SonEQFree.vst3 but SonEQ in my vst manager. So Cubase is unable to link it to my project. I tried to edit the xml file to use the former name but nothing changed in cubase…
Is it possible to link a missing plugin error to an existing plugin like what’s possible for missing samples ?
I know it’s the plugin developper fault but they don’t reply and they didn’t planned to restore old plugin name…
For kHs Gain, it is different: the plugin is the same, same name etc… But it’s marked as missing… I don’t understand why ? To be able to link missing plugin to installed plugin would be a solution.

Sorry for my english.
I really need help for this since I use these in all my projects.
Thanks a lot

Hi and welcome to the forum,

As far as I understand, the SonEQFree has been installed in two versions:

  • VST3
  • VST2.

VST 2 version of the plug-in is probably older than VST 2.4. Cubase 12 doesn’t support these old plug-ins anymore. Therefore you don’t see the plug-in in Cubase and you have to use the VST3 version.

It’s probably the same story with the other plug-in. Probably the plug-in is not VST 2.4 or higher, therefore Cubase 12 doesn’t load it.

I think I only installed vst 3 versions, even with the old installation. Is there any vst2 xml file that I can try to edit to change the name?
Any ideas for kHs Gain?


In the Cubase preferences folder, you can find the blocklist XML file. You can see the list of blocked plug-ins in the Plug-in Manager too and you can enable the plug-in (at your own risk) in the Plug-in Manager too.

Maybe I’m not clear enough.
They are all vst3 64bits plugins
No plugin in blocklist
SonEQFree is now SonEQ and cubase consider it as another plugin.
kHs Gain is 100% identical but cubase don’t understand it so mark it as missing.
I’m stuck

Cubase doesn’t care about the name of the plugin, it only uses an internal id of the plugin to identify it.
If you installed a new version of a plugin, and it doesn’t load in old projects where you used the old (probably VST2) version, that means that the new version uses a different internal id so Cubase thinks it is a different plugin. There is nothing you can do about it, except install the old version.
Sadly, very often plugin developers, when moving from VST2 to VST3, use different ids for the different formats, and they don’t use the backward compatibility feature of VST3 that enables it to load in projects that previously used the VST2 version.
Only the developer can fix that.

I’m 100% sure I never used a vst2 for these two (and for all my plugins), I don’t even install it.
I’m not sure about the plugin id because I tried with cracked versions of plugins I own (legit, bought, don’t kill me please) and it worked (with vst3 versions of course).
So it’s not a vst2 / vst3 problem because I never install vst2 version…

I wonder if that can happen even if the plugin itself never created a v3. I think it happens to me with v2 plugins as well. I’m sure I’m missing something because it would be very weird for some major plugin developers to not have backward compatibility for older project, as it would typically be a deal breaker for most users.

Did you ever fix this?? I have the EXACT same issue- with same plugins.