new machine. Cubase needs to be forced quit everytime

I have a brand new machine with a new windows install and cubase 10.5.x I still have to force quite cubase 90% of the time. I’ve seen various threads on this, has anyone narrowed down the cause? I know rewire can be an issue but I don’t use any application that uses re wire so it’s not that. I used to get it from time to time on my previous machine and had hoped a new install on a new machine would cure this but no, I’d say it’s worse now.

I’m sure it’s plugin related, has anyone worked out the culprits?



I thought I read that if its an older rewire version then it can cause an issue regardless if you use rewire or not.

Try SAFE mode and see if it does the same thing on Quit. Cubug has had this issue for YEARS and I don’t see it going away

thanks, I don’t use re wire so I have a default, new install.

Safe mode? is that a cubase safe mode or windows safe mode?


Brand new install, new, clean win10 machine, no rewired components at this point, and I can confirm I get a hang on quit about 1 out of 5 times.

It usually just hangs for a sec (1-2), and then closes normally, but sometimes I have to kill it. Fortunately all internal processing has completed, projects and data are all saved normally, and then the application itself hangs on quit for some reason.

yes, exactly the same here. You’ll find it’s not in your recent projects though if that’s important.

I’ve tried quitting from the file menu as well as from the red ‘x’ on the window but still the same. I@m sure it’s a plugin but I just haven’t got the time or patience to go through them all.

Here’s what I have on a recent mix, so all audio. this project stalls on quit.

Acustica Aqua gold and ultramarine EQ/comps/channel strips, Slate tapes, Slate console, Cytomic the glue, Aether reverbs, Eventide SP16 reverb, Valhalla delays. everything else from cubase.

actually that should be fairly easy to track down.

I’ll report back if I find a culprit.


Ahh, true - - project does not make it into recent if the process must be killed.

Just upgraded from Cubase 5, and I can confirm the exact behavior, with projects not making it into ‘recent’ many times in this manner.

Right now I am only using steinberg stock components as I build and rebuild my new environment, and when stock it rarely if ever has to be killed, in my experience.

Sorry, slightly off topic but I AM IN HEAVEN!!! Have been waiting many years to buy a full, modern, pro license, and I got it 3 days ago!!! There are dark circles under my eyes, and I’m running in 2 hours sleep today, but I am happy!!! : )