New Midi track when I Drag and Drop midi Groove

Every time I drag and drop a Midi groove from EZ Drummer to my Instrument track it create a new Midi Track with the name of the midi files, I did remember a problem like that some time ago and all I did was to check mark the " Import drooped Files as single Part" in Cubase Preference but now I can’t get it to work !!!


there’s a preference somewhere for this,and I can’t for the life of me remember where exactly, but it’s not the one you stated…sorry.


You need to change between musical and time mode. The icon is set per track (like the EZ drummer track). The icon will change from something that looks like a clock to a note with orange background (at least it is orange in CB 5.5).
Now you can drop your MIDI grooves in the EZ drummer track. It will however rename the track from EZ drummer (or whatever you call it) to the groove name. Annoying that too!

Under Preferences->Midi->Midi File->Import Options, make sure that the drop down at the bottom has “MIDI Tracks” selected as “Destination” and NOT “Instrument Tracks”, ALSO, make sure “Auto Dissolve Format0” is NOT checked. This seems backward for what you want to do, but if you have “Instrument Tracks” selected as destination, when you try to drop the Midi file into the project, it will create a NEW empty instrument track instead of putting it on the track you dropped it on.
As rumdrum mentioned, make sure the Instrument track you are dropping onto is in Musical mode.