New to 64 bit, having Waves VST problems

I recently upgraded from Cubase 2 to 6. I’ve read all over the net about issues with Waves plugins not working on a 64 bit system. Well, now I’ve experienced it. I’ve had some very odd things happen. Like installing the plugins and finding only the vstshell.dll in the folder and nothing else. The one thing that hasn’t happened is getting them to work. At all. Period. This is very disappointing because I’ve got all those recordings I made with C2 that are going to give me a ton of grief when I try to load them into C6 because they won’t be able to find their plugins. So…anybody out there having any luck getting Waves VSTs to work in C6 64 bit?

Windows 7 Professional 64 bit
3.3GHz AMD Phenom II X 6 core processor
640 GB SATA III system drive
3 - 2 TB SATA III data drives
16 GB Ram
ATI Radeon HD 4200 graphics
Cubase 6 64 bit
Tascam US-1641 USB audio interface

Waves wraps all of their plugs within their Waveshell - which doesn’t play nice with the VSTBridge.

You’ll need JBridge (http://jstuff.wordpress.com/jbridge/) for Waves. It’s cheap. Works fine.

js

You’re right. Thank you.

Or alternatively you can use the 32-bit version, where they will work.

I bought jbridge a few weeks ago and now I can use my waves programs in Cubase 64bit. I believe I paid $24? It was worth it not to switch back to 32bit cubase. I run alot of vsts when I’m working so I can’t afford to go back to 32 bit cubase. I hope this info helps :slight_smile:

Waves 8 runs just fine under JBridge in Cubase 6 in Win7. The only plugin I’ve experienced any problems with under JBridge is Soundtoys Devilok, even then it’s just an occaisional crash and I’ve been using it for about a year now.

For some reason Ive been having pretty frequent freezes or “missing waveshell” messages.

From someone else’s post:
“Waves Plugs will not J Bridge successfully on my 64bit i7 Windows 7 system.

Neither the WavesShell nor the vst2shell (de-shelled versions) work properly. Every time I instantiate a Waves plug in Cubase 5.5.1 64bit, RenEQ for example, then manipulate a few parameters, click “e” to hide/show the plug-in GUI, will freeze Cubase completely.

I’ve tried some of the settings that Jaoa has suggested but they don’t work unfortunately. Bummer.”

Those freezes are driving me crazy. I havent tried the shell2vst thing yet, mostly bcz I see posts from ppl that tried it and it still didnt work. Wish there was a failsafe solution for those that do have problems.

Waves is going 64-bit in Q1 2012.

http://www.kvraudio.com/news/18067