New track presets created after upgrading to 9.5 are nowhere to be seen

I am having a strange issue after upgrading to 9.5, and now 9.5.10. I am on macOS 10.12.4.

All old track presets show up just fine. However, new ones I save are nowhere to be seen on my track presets menu. In Finder I can navigate to USER/Library/Application Support/Steinberg/Track Presets - and sure enough, there they all are, both the ones created prior to 9.5 as well as the new ones. Still they will not show up in Cubase. What’s going on, and how do I fix this? Anyone else experiencing this?

Thanks :slight_smile:

Quick update: I tried a workwround by actually REPLACING an existing track preset when saving the new one. When trying to add that track preset to another project, it did not disappear from the list of track presets, having an identical name to a previously existing track preset. BUT when I tried to add the track preset to the project, nothing actually happens. No tracks are added to my project. While adding a track preset created a year ago however, works just fine.

Im just having this issue please help !Im saving my ptrack presets but they are not showing up now…