Newbie - How To Download Cubase AI with Download Access


I just purchased a UR44. I have registered and have an eLicense. I have tried countless time to obtain a download link for Cubase AI (Not sure but is their different versions?, can I download and use my activation for AI 9?). Each time I enter my download access code or eLicense, actually I’m not sure which to use (I have a download access number on a paper card, but each time I enter it it says fails. When I go into my account and go to My Products and click on Enter Download Access Code I enter the Download Access Code on the card and it says it does not exist? When I copy my eLicense code it takes it but says it was successfully registered (but I’ve don this about 5 times now and no download load link to the software. All I get is a "I’m Done? button at the bottom of the page which does nothing?

So my question is what version of Cubase AI am I entitled to, and where can I download it with my Access Code and eLicense?


Hi and welcome,

Follow this instructions, please.


Sorry about the post. I had tried unsuccessfully on many attempts and became very frustrated. I ended up closing done my browser and the trying it once more later, and finally it accepted my Download Access Code, then providing the Serial # of my UR44. So I did eventually download Cubase LE AI Elements 9, and was able to play around with it.

The reason I bought the unit was to capture 6 audio (music) channels (I’m not a musician). This “USB Audio Card” seems the best price with the highest quality (6 channel, 24-bit, 192 kHz). I connected it to my Harman Kardon Home Theater 6-channel pre-amp out to capture the L7 (Logix 7) upmix, and did not connect the UR44 outputs. I was able to record all s channels and see them in the project file location on mt PC. Seems the pre-amp output is very low as I had to add 30dB gain to the wav files in my audio editor. Still experimenting to try and get a higher gain output.

As I said I’m very sorry to post this message but at the time I was desperate :slight_smile:, maybe it would help others who had similar issue.

Thanks for the reply’s anyway.