Newbie needs help adding mic

Hey guys and gals,

I just recently bought Cubase Essential 5 and this is my first day using it. Basically my question is (and I apologize if this sounds super ignorant), how do I add a new mic in cubase? When I push f4 to bring up the screen thingy and right click the mapping thingy to bring up the input selection thingy, all I see is my built in computer mic. I plugged my fancy mic through an icicle USB converting and then directly into my USB port. When I try to use this fancy mic in Audacity, it works just fine. Why isn’t Cubase recognizing it?

Thank you all so much!

Does the mic come with an ASIO driver…?

As the USB fancy mic to usb thingy doesn’t come with any ASIO driver, Cubase probably won’t see it.
You could try some of the other generic drivers like the multimedia asio driver but even if that works the latency will be huge.

I think that downloading the free ASIO4ALL driver and configuring that correctly would probably work.

Yes, Indeed…

:arrow_right: Here is how to configure USB Mics and ASIO4ALL.

  1. Download and install ASIO4ALL:

  2. Open Cubase and go to “Devices–> Device Setup–> VST Audiosystem” and select ASIO4ALL as Asio driver. Apply the changes.

  3. Now go to the point under “Devices–> Device Setup–> VST Audiosystem” called ASIO 4 ALL. Click on Control Panel.

  4. In the WDM Device list of the ASIO4ALL control panel activate your USB Mic and the respective Inputs. You might have to activate the advanced view for that.

  5. Now go to “Devices–> VST Connections” and go to the Input tab. create a new MONO Bus. Now select the USB Mic input as Device Port for that bus. If you want to you can also rename the bus to for example to “USB Mic Bus”.

  6. Now create a MONO Audio track, Project–> Add track–> Audio

  7. As Input for that track choose the newly created Input bus in the inspector.

  8. Now record enable the track and you’re ready to go.

If you have a audiointerface with a dedicated driver it is not advisable to use a USB mic as it most likely will only work with a generic driver like ASIO4ALL.

USB Mic’s are not ideal for DAW setups and I would not recommend them for Cubase users. :frowning:
Instead I would recommend an ASIO audiointerface and a mic with a common XLR connection.


Wow thank you all so much for the quick and helpful replies! Truly! You guys make me glad that I bought Cubase lol.

Sorry, one more thing though. I’ve installed the ASIO4ALL driver and… my mic works now! Thanks a lot. But now my speakers don’t work =(. When I open my f4 menu thingy, I can’t find my speakers listed on the output section. Any idea what’s going on?


At a guess (Never used ASIO4ALL) have a look at the asio4all settings.