NI Komplete M32 Transport Controls

Hello there, in Cubase 12 I can’t use Transport Controls anymore, anyone knows why? I’ve tried to use the midi remote to map buttons on my keyboard to a specific function but, Cubase recognizes it as working knobs just the 8 knobs on top, and every other button is ignored.
In Cubase 11 I could use transport controls smoothly, it was working just with plug and play.

No issues here, have you checked the Remote Device (legacy) properties for KK in Studio Setup?

Nope, could you explain how? Thank you :pray:

Go to Studio → Studio Setup → Remote Devices (legacy) and make sure that the "Komplete Kontrol A/M - Series is listed. If so, click on it and make sure that the KK Daw M ports are selected.

OK, I tried, but I don’t have any of this on my studio setup. I’m on Macbook M1. :\

Sounds like you don’t have the NI scripts for the M32/Cubase integration but cannot confirm unless I see a screenshot. I know on Win, that the script’s are installed with the KK software. Have you tried reinstalling that? Not even sure if NI offers them anymore…would need to contact NI to verify.

I’ve reinstalled it already! Nothing to do! :\ do you know If the the scripts are installed in some specific path?

I am on Windows, so I am not sure about the Mac install path… again to find out for sure, you would need to check with NI. Either as on their forum or search their support page…

Don’t know how much this will help you since I’m on a PC. But I had the same identical problem as you, and eventually discovered that I no longer had NI Host Integration Agent on my system drive. That gets installed with Komplete Kontrol … BUT … if you had the Host Integration Agent at one time but for whatever reason, don’t any more, first you need to use the NI Registry Uninstall tool to remove anything related to Host Integration Agent (by uninstalling within the tool). If you then reinstall Komplete Kontrol (over the existing on seems fine), the M32 will come to life in Cubase. I didn’t even have to set anything up in Remote Devices - it just automatically worked!

I would guess there may be something similar to be done on a Mac if the cause of the problem is the same as mine, though I couldn’t tell you what the Mac version of the fix would be. I hope this helps in some way …

Pete

@Giacomo , on the Studio setup screen, if you click “Add Device” at the top, does "Komplete Kontrol A/M - Series show in the list? If so then select it and then select the proper midi drivers (The DAW Driver) and again, if it does not show, then contact NI!

Nope buddy! I don’t know why! I’ve already asked on NI forum with no luck! :


The problem is that NI Software not working under apple silicon. This is the reason why!