NI Komplete S88 MK 2 no recognized by Dorico 4

No matter whether I start my Komplete S88 MK 2 keyboard before launching Dorico, it is not recognized as a MIDI input source and I cannot use it in Dorico. Works fine in all other apps from Nuendo over Sibelius to Studio One. Help wanted urgently, please (either in German or English), thanks in advance!

Can you please connect your keyboard, start Dorico and then do Help > Create Diagnostics Report and post the corresponding zip file here? Thanks

Same here. I’ve tried the normal Komplete Kontrol driver, the EXT, and the DAW: none work. I have a Roland A-800 Pro that works fine with Dorico. My Komplete Kontrol works perfectly in Cubase Pro 12 running off the same computer and hardware setup. Mine is also an KK S-88 Mk2.

Dorico (3.7 MB)

Hi @SF_Green , thanks for the data.
According to the logs it does get recognized but in your preferences it is disabled as MIDI input device.
If you go to Edit > Preferences, choose the Play tab and scroll down until MIDI Input Devices, is the Komplete listed there and also check-marked in front?

Yes it is there, and no it is not checked. :roll_eyes: You have correctly identified the source of pilot error. Hopefully, you can get @abeschorner taken care of as easily.
Vielen Danks


The report is too big… Shall I drop all but one specific folder?

Just send the AudioEngine folder

And the preferences.xml from the Dorico folder, please

Here you go! (2.2 MB) (3.7 KB)

Thanks for the data. According to the log files the Komplete does get recognized by the audio engine. And since MIDI input is enabled with you, I would expect it to work with you. How about the preferences dialog on the Play tab, is it really not listed under MIDI input devices?
And when you hit a key, there is no little green light flashing at the bottom right corner of the Dorico Window?

Hi Ulf. Exactly as you state it. Works with everything else, as mentioned before.

@abeschorner , I had a look again at the logs, but can’t find a clue, why it would not work with you. The only thing I could think of is, do you have Nuendo open at the same time, resp. started before Dorico. In that case it won’t work, because Nuendo grabs the MIDI port exlusively and prevents other programs from using it.

Greetings again,
I don’t have any other app running except for Firefox and potential background processes I have no influence on. Grabbed an Arturia keyboard from a mate yesterday which works flawlessly.

@abeschorner , I’ve sent you a private message, did you see?