Nightmare on Audio / External Instruments Routing street...

Although I’ve read the getting started & scoured the web I’m struggling with this & would really appreciate some help! :confused:

As there are SO many ways of doing things in Cubase it’s flexibility makes it hard to just get the basics up & running

SUMMARY
“Looking for the easiest setup to allow me to create projects using VSTS AND External Midi Synths & mixdown the audio from them all”

I have a lot of external gear & want a simple workflow which avoids having to setup each instrument individually in great detail to be able to use it

I’ve looked everywhere for a diagram with examples of how to physically connect this to this along with the softwaer settings but no joy

IN MORE DETAIL

This would be so much easier to explain as a visual diagram but here goes!

Summary of current situation

1. A number of Hardware Synths / Drum machines are connected into 2 Audio patch panels

2. I don’t have a big enough mixing desk for all those audio outputs from the patch panels so I take as many as I can into the two small mixing desks I have until I have no more inputs left. I can use patch leads to change which gear I hear via those Mixing desk inputs if I wish

Some go into a Peavey Mixing desk then the main OUTPUT from that desk goes into the INPUT of my Phonic desk along with more gear via the patch panels

3. Output from VST’s / samples etc within Cubase come OUT of my M-Audio 24/96 Soundcard in my Pc into an INPUT on the Phonic desk

4. The main OUT from the Phonic desk goes INTO my M-Audio 24/96 Soundcard in my Pc

5. when I’m working in Cubase I listen to the output via headphones in my Phonic desk so I can hear everything from any input / output & I am under the illusion I am cooking on gas - even applying cubase midi effects to external kit like Beat designer are working well & sounding great…

Until I try to export the whole lot as an Audio mixdown!

This is where it gets confusing for me…

I can create a project with VST’s, create Midi tracks utilising external hardware Synths & I can hear everything

Of course when I mixdown I only get the Audio tracks as my external instruments aren’t set up properly

I don’t know whether I need to:-

1/ Open the VST Connections window from the Devices menu. 2. Open the External Instrument tab and click “Add External Instrument”." and add for each of my external hardware synths

None of my Synths are listed & even if I had the option of create new (which I didnt notice last time I looked) do I need to spend hours creating synth specific info?

2/ Create a midi track with a corresponding Audio track & somehow link them??

3/ Create an Instrument track which combines both?

4/ Not sure if I need more physical Inputs / ooutputs on my soundcard


Seems such a simple requirement - “Record vsts & external Synths” but seems hugely complicated & that’s before I even start with effects busses & what not

I would be really grateful if someone could give me a 'human answer to this - rather than page 245 - read the manual etc.

Manuals serve a purpose but I don’t think you can beat a good answer from fellow musicians who have been through the same process already & found the best way though

Thanks in advance!
M

So you have the sum of all the external hardware sound coming into Cubase as a single stereo signal?
If you do all the mixing on your hardware mixers, then you could just create a single stereo audio track and set the inputs to the incoming stereo input from your mixer. Play back all the midi tracks that control your hardware, and at the same time record the output into the audio track. This is something you can export.

However, if you want to make changes later, you are stuck with all the hardware sounds in a single file. You can record as many different instruments simultaneously as you have audio inputs on your audio interface, however with your current setup that would mean you’d have to replug every instrument when recording. Doing it that way you get every instrument on a different audio track and you can use the Cubase mixer and effects on specific instruments instead of on the entire hardware mix.

I hope that helps :slight_smile:

Thanks for wading thru my post! Very clear comments

Scenario 1
“So you have the sum of all the external hardware sound coming into Cubase as a single stereo signal?”
Yes. I had a feeling that wasn’t a great idea…

“If you do all the mixing on your hardware mixers, then you could just create a single stereo audio track and set the inputs to the incoming stereo input from your mixer”

Right. Not looked at Audio tracks in detail much so presumably create NEW Audio track, then there is a properties dialogue somewhere I need to select 24/96 as the Input device? I did try to create an audio track but couldn’t figure how you selected inputs for it. Hard when I’m not in front of Cubase at the moment too! will have a look later

Scenario 2
“However, if you want to make changes later, you are stuck with all the hardware sounds in a single file. You can record as many different instruments simultaneously as you have audio inputs on your audio interface, however with your current setup that would mean you’d have to replug every instrument when recording”

Damn! My holy grail was to have all sounds on a different channel so I could process as appropriate using internal or external kit :frowning:

So, what is limiting me is my Soundcard then…

Quick google of the USB Audio Interfaces on on M-Audio’s website & you’re looking at a measley 4-8 Inputs & as much as £600 for the pleasure!

I would imagine there’s plenty of non Professional musicians out there with 10+ midi hardware - what do people usually do? (Answer : Chuck their hardware & work with VST’s only?)

I guess the easiest / cheapest approach would be to mix using my hardware mixers to create a single stereo audio track as you first suggest?

Sounds like what you suggest will all work & you’ve not mentioned it, so can I assume I don’t need to bother with the "Add External Instrument” malarky with my setup as it is?

Thanks again you’ve really helped

Not really. When creating an audio track it’ll ask you how many you want and if it should be mono or stereo, nothing else. With your newly created audio track, you can set its in and outputs on the left of the screen.

Thanks again you’ve really helped[/quote]

You are welcome :slight_smile:
I have some more comments to make but dinner is ready, I’ll be back!

Ok. created a new audio track & recorded the sum of my mixers into that stereo track - GR8! Progress at last :slight_smile:

Recorded it & as I listened via headphones all sounded fine

However, when I play it back it’s ok for a bit then I get a drop out of 5 seconds or so then it carries on. Weird!!

Have re-done lots & sounds 100% when recording but drops out almost the exact same place every time??

Back to my latency troubleshooting horrors (See my other posts) thought it was 99% sorted apart from drifting out a bit after a while but maybe the drop outs are related too?

System doesn’t seem to be stretched at the time, Asio use is lowish & CPU etc all ok. Running DPC latency checker again it looks fine when running but as I quit Cubase its a sea of red hinting at a device driver issue. I have cut things to the bone - no surplus at all but still somethings annoying it - ahhh! Just seems to be one thing after the other…

Any ideas on the drop out front? I think I am now thanks to you very close to a working system

Any ideas on the drop out front? I think I am now thanks to you very close to a working system[/quote]

Just wondering… could I have set my M-audio sound card buffer too low? down to 64 now

still weird that it drops out in almost the exact same place each time

It’s indeed odd if the track drops out every single time at the same spot. 5 seconds is very long as well.
You can experiment with your latency of course, that’s easy enough. You can change it in Device setup, VST audio (where you select the Maudio driver) and hit control panel. That should popup a little window from the M-audio driver where you can change the buffer size.

Is there anything special in the track at the point it drops out? A certain plugin?

5 sec was a rough guess to be honest - definitely noticeable tho. Will try & time exactly if it helps

You can experiment with your latency of course.

Hi, Yes that’s no probs. I have tried it at most of the values on & off but I thought it was behaving ok at 64… Maybe not - will try again

64 is the lowest value my card lets me select. I think my card is showing a latency of just over 2Ms In & Out - not sure if that’s good or bad but never had a problem before when it was used in my previous Setup (Older Pc / Xp / Different DAW yet even more midi gear connected up).

Sure this is all down to having that holy grail configuration of your PC & Daw yet seems so elusive

"…anything special in the track at the point it drops out? A certain plugin?"

No…& when you listen via the mixer headphones as it’s recording, it sounds perfect throughout.

The shape of the audio wav which is created in the Audio track in Cubase even looks ok - (no spike or flat line or visible difference when the Audio disappears from the rest of it)

So…I assume the Source is ok, it’s recorded ok but when you try to play it back it’s not rendering it properly or something ??? A software glitch or cubase setting maybe


Thx again!

You can easily check if the actual recording is fine by going to the location where you saved the project. In the project folder should be an audio folder where all recordings are stored for that project. Play it back in a media player (depends in what format you recorded if they’ll actually play it, but if it’s 16 bit 44100 Hz it should be fine.)

I’m guessing it’s not the recording though, if the waveform is right then it’s probably fine.

Bizarre!! Yes the recording is fine playing via Winamp… Tried playing it back again in Cubase & it drops out again same place & it is for about 5 seconds

Not sure where to go next??!!

Really strange. Only thing I can think of is you accidently automated the mute or volume fader perhaps?
Really no clue though, it must be something simple and stupid :stuck_out_tongue:

Think you must be right! I guess Cubase is clever enough to record ‘every’ action I do when I’m recording, so muting is prob the answer

I still don’t think my latency issues are sorted properly as I can’t use as many external instruments as I used to with my old crappy (Non Cubase) setup & things that do work sometimes get out of time on playback

However… I managed to get things going long enough to record this last night :-]
http://hypnoticbeats.co.uk/tmp/Hypnotica_System_RebootingV2.mp3

Thanks for all your input