No audio from MIDI files

Hello, everyone. I’m new to MIDI, and I would like some help. Here’s what happened:

I extracted MIDI files from Guitar Pro 5, and I’ve imported them to Cubase. When I play, I get no sound.
I have no experience whatsoever using MIDI, so it’s probably just a rookie mistake, maybe I didn’t set up the outputs or the VST correctly.
Can somebody help me, as I haven’t found any useful threads here?
(BTW, the MIDI file plays just fine on Windows Media Player, and audio files play normally on Cubase)

My DAW is Cubase LE 7, my OS is Windows 10 32bits, intel Core i3. My audio interface is a Focusrite Scarlett 2i2, but it’s not currently plugged in the computer.

MIDI is just the notes in the editor (to explain it simple) … so in WMP, there are some sounds to play the midi files, but in Cubase (as its pro) you wil lhave to assign an instrument (say Retrologue) to hear the result.

Sometimes a MIDI file contain one track, sometimes its multiple tracks … like “guitar - bass - keyboard”, then you choose what instrument goes to wich track. So yo ucan,with Cubase, assign a synth to a guitar track, as WMP will try to put a guitar sound on the guitar track etc etc

So input the midi file on a cubase midi track, then add an instrument track with a VST, go back to the MIDI track inspector and assign the output to the instrument track you’ve just created…press play…voila :wink:

Ok, I did that, I put the MIDI file, then I created an instrument track, and I selected the Halion Sonic SE, (the only option there) as an acoustic guitar
Then, I went to the MIDI track, and on the output options, there were these options: GM Device (Microsoft GS Wavetable Synth), and VSL-Out (1-10)
I tried selecting the GM Device, and checking it on the Instrument track, and nothing.
I also tried selecting VSL-Out 1 as the MIDI output and VSL-In 1 as the Instrument input, and still nothing

What am I doing wrong here?

Try dragging your midi to the instrument track. Insert a vst instrument (like Halion Sonic SE) and choose a sound. The default output for the instrument track will be the main stereo out channel. So assuming you have your audio interface set correctly in the Cubase VST Audio System menu and the output bus set correctly in the Cubase VST Connections menu (output tab), you should be all set.

You say you are a rookie. So, I’m guessing that it is possible that your audio interface may not be setup correctly. The problem is, you didn’t list what it was or list anything else about your computer. The more specs the better when it comes to asking for assist. Also more detail about how you currently have the AI driver and i/o buses set will assist us to assist you.

Regards. :sunglasses:

True, its was the simplest method, draggin the event to an instrument track.

And yeah maybe the sound card is not well configured i nCubase.

My DAW is Cubase LE 7, my OS is Windows 10 32bits, intel Core i3. My audio interface is a Focusrite Scarlett 2i2, but it’s not currently plugged in the computer. Is that necessary? Because I’m not recording anything, I’m just dragging MIDI from Guitar Pro 5, and audio files are playing just nice on Cubase without the interface plugged in. The outputs are set to my speakers (and since sound is coming out of them when I play audio files on Cubase, I guess it’s all set correctly.)

I tried dragging the MIDI track into the instrument track (once I’ve selected Halion and Acoustic Guitar sound), but there’s still no sound at all. Is something set wrong? What else can I do?

A couple of questions. If you can post screenshots it might make things easier.

  • What driver do you have set in the VST Audio System menu?
  • What is the output bus setup as in the VST Connections menu?

Regards :sunglasses: