No Audio Import possible into sampler due to change of file format to FLAC

Hello,

I just noticed that I can’t import my recorded samples into the sampler track anymore because the sampler doesn’t accept the FLAC file format. When can we expect a support or a fix?

Kind Regards
Paddy

I don’t think Cubase has ever supported FLAC files for the Sample Track. According to the manual it is only wav, aif & rex. Checking the 9.5 manual (The Sample Track was introduced in 9.0) it is the same there too.

Just import them to the pool convert them to WAV and then you can use them on the sampler track…

1 Like

Hello together,

yes I just did that. But I’m asking if they plan to support this FLAC Format in the future because they made the decision to switch to FLAC for the recording by default now. I think for us as users it’s not very efficient overall to do the first step for recordings but don’t consequently doing the next step as well (to also make it allign with other features).

Thanks anyway for your comments.

Kind Regards
Paddy

Hi,

The root of the problem is somewhere else, IMHO.

As you can verify, even MP3 files are not supported. And also the files are not resampled, if you import a file with other Sample Rate than the Project Sample Rate is.

It points to the fact that the common Import Option dialog doesn’t appear, if you drag and drop directly to the Sampler Editor. So the file doesn’t go thru to common import process (changing the file format, resampling, etc.), which is triggered, when you drag and drop to the project directly. This is the main issue, I would say.