No audio playback after recording with ASIO4ALL

I own a Blue Yeti USB microphone and have been recording vocals in Cubase 6.5 for a few years now. In order to record with the Blue Yeti I had to download ASOIO4ALL, and it has worked flawlessly. I recently upgraded to Cubase 8 Pro and now I can record successfully using the Yeti and ASIO4ALL but can’t hear the playback unless I switch to ASIO LOW LATENCY driver. This, of course, is unworkable when recording vocals and listening to playback over and over again throughout the recording process. Does anyone know why this worked in Cubase 6.5, but now doesn’t in Cubase 8 Pro? I tried recording the Blue Yeti using ASIO LOW LATENCY driver in Cubase 8 Pro unsuccessfully.

If this can’t be solved I will have to invest a total of around $600+ for a Audio Interface, a new Dynamic or Condenser microphone (Yeti has no XLR or 1/4 inch out) and since I’m using Harman Kardon desktop computer speakers - which also do not have the proper connections for the audio interface - I will have to invest in new monitor speakers. I would like to avoid all of this if I can. Please help, if at all possible, for a solution in getting ASIO4ALL to work properly with the Blue Yeti mic in Cubase 8 Pro as it did in Cubase 6.5.

If there is no solution, maybe someone knows of an alternative USB mic that would work in Cubase 8 Pro, saving me lots of extra investment as noted above.

Thank you

You could use the headphones out, and connect to a line in of a real ASIO interface. But it seems to me your problem is that asio4all is configured differently in your new setup. If you still have your Cubase 6.5 installed, check that they have the same settings, just to eliminate that.

Hi there

I have Blue Yeti on one of my machines with Cubase Elements 8. I just tried it out with ASIO4ALL and it worked fine. I did have toTO fiddle with the ASIO4ALL control panel a bit as it was trying to use a different interface but it worked fine eventually so hang in there I’m sure you’ll figure it.

Best Regards