No connection with Logitech 930 C

I cannot use my Logitech 930 C camera in VST Connect Performer 5.5 (Windows 10). The Logitech is displayed in the selection menu and can be selected, but a message appears that the Logitech cannot be activated.

In Settings/Privacy/Camera - Allow apps to access camera is turned on. In other applications the Logitech works.

What could be the reason for this?

Anybody else with that cam? Have many many webcams but not this one.
What is the exact message? You may also try to remove “Logi Capture” (it is ignored by VST Connect anyway, as it causes all sorts of problems) or temporarily disable/uninstall other Logitech stuff that has been installed.

Sorry, I’m just now getting around to replying.

The exact message is: “Cannot activate video input C930c”.

It should be noted that the C930c is the Chinese version of the C930e. Uninstalling the Logitech software did not change anything.

It simply means that Windows did not accept this camera when building a filter graph. That is quite unusual. Even more unusual is you saying ‘In other applications the Logitech works.’.
We have piles of Logitech and other cameras and none of those fails. I will try to see if I can get hold of one of your type, but probably it will just work like all those other cams we have, still suspect some other software or driver you have installed. Let me check if we can find one.

Just ordered one, supposed to arrive at around mid May.

Yes, the camera works fine under Zoom and under the Windows camera app.

Thanks for your effort.

Hi @musicullum

Two supplementary notes:

  1. I wanted to exclude that it is due to my DAW and therefore tested the Logitech camera on my ASUS laptop (also Windows 10) with VST Connect Performer. There is the same problem and the same error message appears. Also on the laptop, the Logitech works with Zoom and with the Windows Camera app.

  2. Since I have not mentioned it yet (and it is probably not relevant): I also own VST Connect Pro 5. there I can of course also not select the Logitech and the same error message appears.

Hi @musicullum

I was able to solve the problem with a workaround!

In the registry, the entries of the camera were partially stored with Chinese characters.:
罗技高清网络摄像机 C930c

I have now deleted these Chinese characters in the registry (the entries are now only called “C930c”) and I can select the camera in VST Connect without error message. So it seems that VST Connect (in contrast to Zoom and the Windows Camera App) has a problem with the chinese characters.

wow, what a great finding, thank you so much!
That should enable us to fix this with the next version.

Got the cam and problem reproduced. In my case, it said ‘Cannot activate 罗技高清网络摄像机 C930c’, so it would have pointed immediately to a character encoding issue.
Anywho, next version fixes the problem, thank you very much for pointing to it!