No cursor when stopped. Deleting a part makes cursor jump to new position.

I was on Cubase 8, I ‘upgraded’ to Cubase 10. I used to have a cursor that stretched from the time/bar area down over all my tracks. Now this only happens when I’m PLAYING audio. If I STOP the transport the cursor only appears at the very top, in the time/bar area, which means you cannot use it to see where you are for pasting parts or moving quickly back to a point in a part on tracks in the project. This is a bug right? I mean there’s no way it’s mean to be like that right?

And now, if I use L to set my cursor to the left edge of a part, then delete the part, instead of the cursor staying put so I can paste something in its place in the same place, the cursor just jumps to some other location. Why?

How do I fix these things? Why should I be even looking to fix these things?

You have Video Edit Mode activated.

Thanks Steve. It was enabled by default in the installation it seems since I hadn’t turned it on, or indeed heard of it.