No hold/sustain from midi keyboard.


Anyone know why My keyboards hold/sustain pedal won’t work when I record midi data into cubase?
The pedal works fine on the piano itself but I can’t get it to work when midi in to cubase.


Check filters in Prefs. Is the track Write enabled?

Track write enabled, no filters on in the prefs. Midi input data is showing when I press the pedal on the piano. But when I record it and then use the recorded data with a vst instrument there is no hold, also If I play the piano while routing it through a VST i although the pedal is still showing there is still no sustain when I hold the pedal down?


Well if the sustain data gets recorded and you´ve got no filters set, then certainly the VSTi does not “support” the hold of your pedal…!?

It could be the patch as well. The VSTi may support the controller function but the patch hasn’t been programmed to use it. For example, Prologue supports aftertouch but most of the presets aren’t programmed to do anything with it.

So i tried again and recorded some piano, all the sustain pedal info recorded and the sustain works with a couple of vsti’s but not with Halionone? Ideas anyone?


Use one of the couple of VSTis it works with, or try to find a HalioOne patch it works with…

Tried all halion one piano patches and none work with the sustain pedal… Is that right?

Wasn’t there an issue with HalionOne and sustain? A read through the Issues sticky at the top of the forum maight have an answer.

I have a similar problem in my C5

Cubase does receive Sustain midi data, opening the CC 64 Sustain does show 127 whenever I hit the sustain pedal of my keyboard. However, all above is only possible if cubase is not recording. When recording, he does not record sustain.
Any ideas of what the problem might be?

What keyboard/pedal are you using and what does your setup look like? All works fine here in CE5 with a GM keyboard and M-Audio sustain pedal connected to my Vista via USB. :confused:

hi bane,
Thanks for replying.

keyboard - yamaha p95
audiointerface - tascam 1884

It runs fine under cubase sx3, and like i previously told, it only blocks the sustain data (the led on the midi lane stops blinking, no cc64 data recorded) when recording is enable.
when its not recording it works just fine and receives sustain data at CC64 like it should, therefore, I should runout the keybord / audio interface problems out, no?

Also, I checked the filters under preferences / Midi , and sustain CC64 is not listed.

Any clues?
Thank you.

Are you using your Yamaha as a controller as well? That might very well have something to do with it. This sounds like a glitch to me. If you contact support, they will definitely recommend that you switch to C6. :neutral_face: Keep it coming, I know we’ll work this out.

Humm, well, I am using it just as a keyboard, but It is connected by midi cables to the Tascam audio interface which is a controller.
Because I don´t really use it as a controller, I never bother to config the controller to work properly with CS5. But I think you might have a point there.

I will have to check it out and see if I can figure it out.

Thanks a lot!

Is this only with HalionOne or other VSTis as well? This has been a common glitch with Halion in all versions (1,3,4).
Of course, you can set the pedal where you want it using the key editor until you figure this out. Hope you get it working.

BTW, I might trash my prefs just in case, because there is a sustain pedal filter somewhere. :wink:

No, i was experiencing this with an empty MIDI track even with out any instrument plugged.
I did what you told me, and set my preferences to default and it was fixed :smiley:

Thanks Bane. I own you one!!