No key commands after update?!


I’ve just installed the 1.0.30 Update and after that, all key commands are gone?!
I’m using the German language and a German keyboard.

Any ideas?


Is your keyCommands.json file still in the expected place, in %APPDATA%\Steinberg\Dorico on Windows or in ~/Library/Application Support/Steinberg/Dorico on Mac?

Daniel, I’m on Windows 10.

The file is gone.

I really don’t know how that could have happened: the updater doesn’t touch any of the files in that location. Did you happen to keep a backup of the file that you can now restore?

Strange. I didn’t touch this folder at all?!
I got an error message during the installation of the uodate, when I was asked to restart windows?!
I didn’t have a backup of that folder. Can I reinstall Dorico without having to reinstall Halion Symphonic Orchestra again?

Yes, you should find that when you reinstall Dorico it will tell you that the HALion components are already installed, and it will simply skip over them.

But I do have to download the whole lot?

I don’t expect you need to reinstall at all. If Dorico itself runs except for the fact that your custom keyboard shortcuts are no longer found, then I expect all you need to do is (unfortunately) recreate your shortcuts.


first of all: Thanks to the Dorico team for the new update!

Regarding the post: Any solution available already, HeiPet? Did it work after a new install of Dorico?

I am on Windows 7, german keyboard, english surface. Even (some of, I just checked two or three options?) the built in shortcuts are gone. I never customised them, yet I can not change between Setup-Write-Engrave etc. with Ctrl+1/2/3/4/5. There is no keyCommands.json file in the %APPDATA% folder…

When I call Help-Key Commands, the page (Mozilla Firefox, most actual version, Anti-Virus shut down) stays empty, no options are available, the search of “write” did not yield a result:


I witness the same problems. OS 10.12.3, German version with German keyboard.
All shortcuts gone, help/key commands is empty.

Help! I have to work…

Hi Daniel and wolframd,
my Windows system got very slow in the last time, so I decided to install my PC again with a fresh Windows 10 version (before that I had Windows 10 updated from Windows 7).
I downloaded the new installer for Dorico 1.0.30 and installed everything from scratch and: still NO key commands at all. So it definitely can’t be a mistake of mine. My key commands list looks exactely like wolframds and there was no key.comands.json file installed.
I noticed, that there are also German translations for Instrument names are missing, which had been in the 1.0.20 update.
Not very funny, as Dorico is not usable in this state …
There is no way, that I can enter all the key commands manually, as syou suggested, Daniel!

One addition:
when I change the language to English, all key commands are available, but when I change back to German, they all vanish again.

I have the same problem. After I installed the newest update not a single key was working: no note Input, not even delete - only text input was possible. After switching to English, everything was okay. Switching back to German: didn’t work again.

I have the same problem. After I updated yesterday, not only the key commands were not working, but Dorico didn’t react to any key at all. So not even Note Input was possible (only with the mouse). One exception was text input, which strangely was working. After switching to English everything was okay. But going back to German, the keys were dead again.

Thanks for confirming that this problem is widespread. I can see that there is a syntax error in the default German key commands file, which is the cause of the problem. I’m very sorry for this problem. Please download the attached file, unzip it, and place it in:

Mac: /Users/your-username/Library/Application Support/Steinberg/Dorico

Windows: %APPDATA%\Steinberg\Dorico

and you should hopefully find that the default key commands are restored next time you run the application. (3.44 KB)

Thanks, Daniel, works fine now.

Vielen Dank, Daniel.
Works perfectly again. (There was only a short moment of panic, when I tried to start DORICO after placing the keycommands_de file on my machine and DORICO didn’t start but showed the error-message: DCOM Connection to program ‘Synsopos.exe’ failed.) But after rebooting my computer everything is okay again.

Thank you as well!
Works fine again.