"No License to upgrade selectable"

I recently updated my Cubase 11 Artist version to Cubase 12 Artist. However, when I tried to run Cubase 12, I recieved a message “Your License Has Expired.” I then attempted to enter my activation code to eLCC again, but the message “No License to upgrade selectable” appeared, preventing me from upgrading my license.
Could anyone please advise me on what steps I should take to resolve this issue?

Please take a screenshot of the licenses shown by the eLicenser Control Center, making sure to hide your eLicenser serial numbers. Please also check your receipt/purchase confirmation email for Cubase 12, to make sure that you purchased the correct upgrade from your old Cubase license.

It’s likely that all you have to do is click the Maintenance button to the top right, then run the Steinberg Activation Manager and refresh it.

Thank you!

I’m going to make sure to hide my serial number next time.
As you advised, I clicked the maintenance button, then ran the Steinberg Activation Manager and refreshed it, but it says “verification pending expired.” So, I clicked ‘more info…’ button and tried the process suggested on the homepage, which is :

  • Open the Steinberg Download Assistant.
  • Enter the Download Access Code at the top left.
  • A dialog box opens, prompting you to activate the corresponding license. It also shows an Activation Code. You don’t need to write it down.
  • Click on the [Upgrade] button.
  • An eLicenser Control Center window opens. The Activation Code has been filled in automatically.
  • Select the license you want to update/upgrade.
  • Click [Continue].
  • Click [Upgrade License].

However, the same message in the image that I uploaded appeared(no license to upgrade selectable). I don’t know what’s wrong with my cubase 12.

thank you for reading this long message…


Could it be possible that your Cubase license was upgraded to the Steinberg Licensing?
So the license is no longer on the eLicenser but can be found in the Activation Manager.
Check these places:
My Steinberg

And the activation manager itself:

I had a similar and unexplainable case (with Iconica Opus).
You may want to contact Steinberg support with your issue.

This also on nice to know:

I was able to solve it by watching a YouTube video titled ‘Cubase 11 to 12 Upgrade Licensing Problems Walkthru and Fixes’.
Thank you for helping me!

1 Like