No midi in.

I am running dualboot on Mac and Win7 (64) partition - mostly Win for Nuendo.

I havent used midi since I upgraded my computer (used to have a Midex…)
But now I would like to do some midi again.

Midi works fine on the mac partition - no problems, but in Win partition Nuendo (and other programs I have tried in Win aswell) I can se the keyboard as “midi in device”, but no input is given!? (And yes, all the right buttons have been pressed in project).

So, It does not seem to be a Nuendo issue, do any of you have suggestions?

I have tried three different midi-keyboards. I have tried using the fireface midi input and USB with same result.

Thank you so very much!


This is my problem too. I see that your reply was private. Can you give me any insight as to how to get sound again?
I think I have everything hooked up correctly, but I can’t get any MIDI sound when I play live. On playback it plays my MIDI keyboard but when I play the keys there is no sound…the meters move on the Cubase program but no sound or no recording information.


Hi -

Which meters move?

Also - is your keyboard sending audio to Cubase as well as MIDI? If it is - by any chance is your “Local Control” toggle on your keyboard set to off?

Thanks for the reply.

The MIDI input on the Transport bar, the MIDI Fader on the LEft and the track info (MIDI) are all registering activity when I play a note on the keyboard.

When I hit play, it will play back the prerecorded tracks. I can mute or solo any of them and they all have individual activity. I can sol an separate all prerecorded audio tracks too.

I have MIDI Thru on

I don’t know what else to try.

Thanks for the Help!

  1. Do you have audio cables coming out of your keyboard and going into Cubase? I’m just trying to get a sense of your set up. I’m not an expert, but I’ve done my share of gnashing of teeth for similar problems.

  2. “Local Control”. What kind of keyboard do you have? Most of them have a toggle named something like local control. If mine is toggled off, I think I have exactly the same situation you have. The purpose of the off toggle is so that when Cubase sends MIDI to the keyboard to send play it only plays once. But with “Local Control” off (or whatever it might be called on your keyboard), pressing the keys manually doesn’t make any sounds.

Anyway, if you get a chance, a detailed description of your set up might help you get an answer quicker: What your input and output to the MIDI tracks are, what kind of soundcard, what kind of keyboard, how they are physically connected, etc.

I use a Kurzweil PC88 - I do toggle the local control on and off (usually off when reocrding so it will only play the sounds in the multitimbral mode) I do have to set the global mode to 32 so it will play multiple MIDI channels at once. Again, wierd that it recognzes it in playback mode.

I have MIDI out to MIDI in on my Tascam US 144
I have MIDI in from the out on my Tascam US 144
the US 144 is connected to the computer via USB

I use an Edriol M 16-DX as my mixer - it is connected to the computer via USB

Right now I’m not even trying to get any VST instrumetn sounds, but when I first hooked up I couldn’t get any of those either…except the groove agent, that seemed to work fine. I’ll go back and double check that.

Maybe you can talk me through the setup and I’ll see if I missed a step or did something backwards???


Does the Kurz have built in speakers to hear the sound? (My keyboard is a Yamaha Motif, and it doesn’t … I need to run audio cables out to hear the sound).
If yes … have you tried to simply play it (no computer, no MIDI, etc.) since you came across this problem?

yes it still plays fine - when I toggle the local control I can hear it live and when I hit playback it is plkaying (Only) the Kurzweil for all MIDI sounds.

Just to confirm, and to act as a “bump” so maybe you’ll get someone else to help out too:

  1. Does your Kurzweil play out of it’s own speakers, or do you need to run audio cables out of it?

  2. You have ONLY the MIDI connections you described above between the Kurz. and the soundcard, right?

Sorry. No the Kurzweil uses external amplification only. The audio cables are connected and the sound works if I hit play or if I toggle the Local to on - then it makes sound when I play.

The MIDI conections are just the two. MIDI in to Tascam MIDI out from Tascam

Keybanger - When I get home tonight, I’m going to try something, then I’ll post back.

In the meantime, and I don’t know if it will work just sitting here at my desk, but what if you:

  1. Turned local control “ON”.
  2. Armed a brand new MIDI track in a brand new project to record, with the input being the Kurz.
  3. Don’t assign an “OUT” to that track.
  4. Try to record a MIDI piece. Then stop.


  1. Turn local control “OFF”.
  2. Assign a MIDI out to that track … to the Kurz, like it sounds like you’ve done in the past.
  3. Playback what you just played live and recorded.

Do you hear what you just recorded? Is there any step in this process that fails?

it registers on the meters still - but nothing is going into the program. I see both MIDI in and out on the transport bar.

But when I shut it down there is nothing recorded

Are you able to show a screenshot of your MIDI track Is/Os (the Inspector Window, if you can), and also your VST connection window?

It sounds like you got the midi IO’s messed up in cubase somehow. If you set the midi track’s input to ‘all midi devices’ and make sure the kurzweil is assigned to ‘all midi devices’ then there’s no reason I can think of why it shouldn’t work.
I can’t remember off the top of my head where exactly, but I think in device setup you can see all your midi inputs and say if they should work on ‘all midi devices’.

dear Strophoid and Alexis,

I finally broke down and deleted and reinstalled everything. I now have a working program. I do have, however, a possible answer to the problem for the next person that has this.

Windows 7 is new to me and (I don’t knowif I did or not) but I may have installed the 32 bit version of Cubase when I should have installed the 64. (I don’t remember which I installed - I installed Cubase twice when I was having issued with the copy protection key) In researching this I tried to figure out the difference between the two and see that the operating system is, indeed different. So…I made sure to install the right one - 64 bit. Everything in the MIDI realm seems to be working fine. I’m going to play for a while. Maybe tomorrow I’ll go to the VST realm and see what’s up there.

Thanks SO much for all of your time and thoughts on my issue. It’s great to have such support!


Great! :smiley:

Glad to hear that :slight_smile:
As a side note: on 64-bit Windows you can run cubase in both 32-bit or 64-bit, whichever you prefer. (64-bit has better performance generally, but some plugins won’t work properly or not at all in 64-bit.)