No MIDI signal with keyboard despite MIDI signal

Hi. I just used Cubase Artist after a little break and the coming of 10.0.30 update, and now I have a problem that I didn’t have before. My USB keyboard is well detected by the software (It appears in MIDI device and MIDI signal is send when I press the keys). However when I want to play with a VSTi, the MIDI signal is not detected and as a consequence, it’s impossible to play or record any sound from any VST, either if I put MIDI in to “All MIDI imputs” or “Digital Keyboard”

That’s the first time I see this problem. Before I just had to connect my keyboard in USB and everything went well. Do you have any idea how to fix it ? Is it a bug coming with the new version of Cubase ? For infomation, I work with a Yamaha YPT-240. And I already tried to reinstall Cubase and my keyboard’s drivers.

Thank you for your time, and sorry for my bad English.

Hi,

Double-chech Preferences > MIDI > MIDI Filter, please. Make sure, there is no Note enabled in the Record section. Only SysEx is enabled by default, it means SysEx messages are filtered out and not recorded. Also make sure any Channel is not filtered out (if it is filtered out, the button shines a bit more lighter).

Double check Studio > Studio Setup > Remote Devices. Make sure your MIDI Keyboard is not used as a MIDI Input in any Remote Device, or All MIDI Inputs is not used.

Double check the Chord Pads is not controlled by the keyboard in the Studio > Studio Setup > Chord Pads (this might be Cubase 10 only).

In the track, do you use the dedicated MIDI Input port or do you use All MIDI Inputs? If you use All MIDI Inputs, make sure your MIDI Keyboard is linked to the All MIDI Inputs in the Studio > Studio Setup > MIDI > MIDI Port Setup (the In ‘All MIDI’ is enabled in the relevant row).

Hi. I just check all of this and everything is as you say, but the problem is still here. Even if I use my keyboard MIDI Imput or All MIDI imput, the result stay the same.

Hi,

Could you double-check MIDI > CC Automation Setup…, please? Is there Use Global Settings in the Record Destination of MIDI CC1 and is the Global Record Destination set to MIDI Part? Isn’t it recorded to an automation track?

Could you try in Cubase Safe Start Mode, please?

The destination is well set on MIDI part. And the problem persist even in Safe Start Mode

Hi,

Can you see an incoming MIDI signal on the Transport panel? Could you add the MIDI Monitor MIDI Insert? Can you see the incoming MIDI data here?

Hi

Yes there’s MIDI signal in transport panel. I add the Insert MIDI Monitor and nothing changes

Hi,

Can you see the data in the MIDI Monitor while recording?

Well I never used MIDI Monitor before, but when I record I see something like this

Hi,

Could you double-check the Studio > Studio Setup > Remote Devices? Isn’t there any device using the MIDI port?

Yes, still no other device connected

Hey, double-post just to say I find a solution. I just reset my preferences and everything is ok. Thank you for your help !

Hi,

Good to hear.