No more Midi input on VST Plugins?


I can’t see no more the Midi input selector introduced on v1.1.30 on the header of audio plugins…

The stranger thing is that the Midi input I selected on a plugin on a older version of VL is still active and working when I open the project in 1.2.1…

Hi @Jihem,

hm …

  1. Start VL, New Project, Select TRACKS
  2. Add an Audio Tracks
  3. Load “WahWah” Plug-In as an Insert
  4. Open the editor of the Plug-In

The MIDI input selector is still there. Where is it missing? Which Plug-In?

Thank you,

I can’t do that anymore… Stack plugins have lost their Midi input selector.

To make sure of what I said before, I reinstalled an older version of VL (1.1.41) and here’s a screenshot of the panel of a plugin I inserted in a Global Stack :

You can see the Midi In selector on the top right. “Harmony” is the name I gave to a Virtual Midi input.

Now, the same project open in VL 1.2.1 won’t show this selector anymore :

Despite this, the virtual Midi link is still working (the plugin receives Midi notes from a track), but I can’t modify it.

I’m in trouble…

Have a good week-end!


… arg, the Global part. Yes, sorry. Fixed now. Next update.
… 1.2.0 should be fine for that one.

Thank you!

1 Like

Well… No :grimacing:
It looks just a bit different on 1.2.0, but still no Midi Input.

Now, I have to uninstall again and reinstall an old version to access this selector :cold_sweat:

The result of a series of uninstall/reinstall is that it works in 1.1.41, but not in 1.1.42 and higher.

I hope it will help you…

Hi @Jihem,

Thank you. It’s fixed. Promised. My info “1.2.0 should be fine for that one” was simply wrong. I had a look again to the code. The bug was there for a long time. The next Friday is coming soon …

Have a nice week,

Thank you so much!

My wish is to load Guitar Rig 6 into a Global Stack and control it with a Midi foot controller. Notes and CC are ok but it seems that Program Changes are not changing the presets. Are these messages filtered somehow?

Can’t wait until Friday, this will be the longest week! :wink:


They would be filtered if you use it in Actions and Shortcuts. Else those should get thru like all other MIDI events, maybe Rig must be set up somehow?

Hi @musicullum , it seems to be a problem with VST3 protocol, as I read on this forum :

The following sentence makes me worry about the possibility to change a VST3 plugin presets by sending PC messages :

VST3 doesn’t have raw MIDI input/output. Any messages that the plugin sends/receives must be formatted as VST3 events. It’s up to the host to convert MIDI messages into VST3 events that will be received by the plugin.

Should I look for a VST2 guitar plugin to achieve my goal?

Thank you for your advice.


Another topic about how VST3 handle Midi messages :

I guess it would be a tough task to code a workaround in VL…

Hi @Jihem,

workaround? It’s like Arne said. Everything’s there and ready for VST3. It’s up to the Plug-In developer to add PC. Insert HALion Sonic, Open the Editor, Select the OPTIONS Page, activate the Prg Changes option …

Screenshot 2023-07-04 at 08.32.41

… now the “PGM CHG” will control slot

… I’ll check it later the day,

Exactly, and of course we do.

That is nonsense. VST3 plugins must follow the VST3 protocol, which promotes all MIDI messages in a well defined and modern format. It is up to the plugin to support whichever MIDI messages it receives from the host. Many plugins don’t support program change in the first place, but nothing is beeing taken away, and Program Change messages are promoted to all plugins receiving MIDI just like with VST2, albeit in VST3 format. Finally, Cubase and VST Live promote all MIDI channel messages to all VST3 plugins in said format.

… how do you want to control the preset-selection with Guitar Rig 6? With your Midi foot controller? Which one is that? Which events will it send if you want to select a preset? Because I found out that Guitar Rig 6 will only select the preset if a Program Change Event only (!) will be send to the plug. Do not send any Bank LSB/MSB messages.

See you,