No MP3 reading/exporting

After a few weeks of happily reading and exporting mp3 files, mp3 support on my licensed Cubase 9 ended.
I’ve purchased Steinberg MP3 Upgrade Patch and activated it. Still - no mp3 support.

Going over the Plugin Manager, I can see “MP3AudioHandler” in the blacklist.
The “Audio-Coded Plug-ins” box in “Plug-in Information” is totally empty.

And ideas what went wrong?


What does it mean, you cannot import/export? Any message displayed?

No error messages.
The mp3 option just disappeared from the drop down menu in the export box.
I can’t drag mp3 file into a track, and when manually importing audio, the option for mp3 doesn’t exist at all. I can force-select an mp3 file, but Cubase ignores it and the track remains blank.

Cubase 9 does not need the upgrade…maybe this is why it is blacklisted…it isn’t copmpatible.

I would try to reinstall or repair your install. Also make sure you’re running latest elicenser and have run maintenance.

EDIT - You can also see if you have the audio codecs subfolder in your cubase install components folder

Thank you Grim.

In the end what solved the problem was upgrading to Cubase 9.5. For now at least we are fine.

Was there any further update as to the cause of this issue? My C9 has been working fine for the last year+, however I have the same issue as mentioned above - I import an mp3 (either Drag & Drop or File > Import) and the error shows that the medium is “unsupported”.

Sorry Biddle.
Only thing that worked for me was upgrading (it was for free since I purchased 9 when 9.5 was already out).