No percussion sound

I have some problems with percussion playback: Sometimes some instrumentes of a drum kit or the whole drum kit won’t play back. This appears mainly after I changed one or more notes in the drum kit staff. Any other instruments/sounds play well all the time.

Most times, stopping playback and starting it again several times brings back the percussion sounds.
I cannot figure out what’s going wrong here. Any ideas?

Thomas

We’ve not seen this problem reported by other users. Please attach a project in which the problem can be reproduced, and some steps to follow to reproduce it. Thanks!

In the attached sample file, timpani and the brass/woodwinds sounds play well. But I cannot hear the Drum Kit.

As said above, sometimes pressing stop and play several times brings back the sound.

Maybe the VSTAudioEngine log file might help – I attached it too.

Thomas
VSTAudioEngine.log.zip (10.4 KB)
Percussion sample.zip (1.58 MB)

If you do Play > Apply Default Playback Template, does that seem to fix things reliably in this project?

Unfortunatly not. I tried serveral things in Play Mode, but nothing helped.

Thomas

I downloaded your test project and I had same issue like you, i.e. the tom toms could not be heard.
Also, playing on the virtual keyboard in the HALion window only produced very few percussion sounds.

But when I did Play > Apply Default Playback Template, everything was back to normal, i.e. also the toms are playing back as expected.
I guess something is wrong with your Percussion Map.

This time Play > Apply Default Playback Template brought back the percussion sounds for me too.

But after I changed some notes in the Drum Kit staff, I don’t hear any percussion sounds anymore. And now, Play > Apply Default Playback Template doesn’t bring them back for me.

Thomas

Could you please post the new example project?

After opening the project today, the percussion is “increasing”: First I didn’t hear any percussion sound, second time pressing play, I heard the toms, third time the rest of the drum kit, fourth time timpani joined the percussion ensemble.
Percussion sample.zip (1.58 MB)

The new sample project you posted does play back correctly immediately here with me.

And that what you describe sounds so weird. With every run a percussion sound is adding up. I see no reason why that should happen; either everything plays or does not.

I loaded your first project again, and this time I noticed, that the Quick Controls in HALion Sonic SE (HSSE) are mostly turned down for the GM Kit.
Open the HSSE editor window and select slot 14 for the GM Kit. Above the virtual on-screen keyboard are 8 knob controllers, the so called Quick Controls.
These controls can be assigned to control any kind of parameter. With the drum kits by default they control the levels of groups of percussion sounds.
Have a look, you’ll see Bass Level, Snare Level, Tom Tom Level and so on.
Now, most of these knobs are turned down or at a very low level, so even though the MIDI playback is working, the level is set so low that you can’t hear anything.
Turning up the knobs and everything can be heard again.

Thank you, Ulf, for your help.

There’s really something weird with my percussion sounds.

I never made any changes to the Quick Controls in HSSE. Is there any other source that could have caused these changes?

Thomas

Yes, in theory any MIDI controller could make such change, if it happens that it is mapped to one of the Quick Controls in HSSE.
But don’t ask me how this actually happened in your setup…

A propos:
My Toms all sound like chopsticks clicking and the bass drum is far too soft. I am no good at MIDI, does anyone of you have suggestions?

Unfortunately without seeing your project, Rune, it’s hard to give advice. Can you attach the project here? Zip it up into an archive first, then attach it.

Even though the project is rather small, I don’t manage to make it small enough to be accepted. I just use the ordinary built-in zipping function in the Windows Explorer window. Sorry about this. Does anyone know how to zip it small enough?

Sorry, I finally managed to make a mini version of the file. Here is the zip archive.
Dum og deiligKORT.zip (474 KB)

Perhaps, for starters you could try to replace the Yamaha.XG percussion map with the General MIDI percussion map…

Rune, open the Edit Percussion Kit dialog, and use the change instrument button (the one that looks like two arrows pointing in opposite directions) to change ‘Tom (High)’ to ‘Tom-tom (Medium-high)’ and ‘Tom (Low)’ to ‘Tom-tom (Medium-low)’, and that should do it. The drums in your kit should then match the drums in the percussion map and play back as expected.