No Playback - RealTek High Definition Audio

Hi,

I have a problem in that I get no playback from Dorico - this is with RealTek High Definition Audio. I’m aware that there are issues with Dorico and RealTek Audio devices, but as far as I can see this in the context of Dorico crashing, which is not the case for me - it’s just the lack of sound.

I have looked through the “Frequently asked questions: try this thread first”, and have gone through the steps under “I get no playback. What do I do?”

To be specific, I have tried looking in the Device Setup: when I click on Device Control Panel I get “Microphone array (RealTek High Definition Audio)”. I’ve then gone through the process of setting up a project with solo piano - and I get “YAMAHA S90ES Piano” in the Multi Program Rack. However when i click on the piano keyboard I don’t see any VU meters lighting up and I don’t get any sound.

I am therefore attaching a zipped version of the VSTAudioEngine_64 as suggested.

My machine is Windows 10 with Intel i5 6200U.

Apologies if I am just doing something stupid.

Incidentally I do get sound from other programs (including a scoring program).

Thanks very much.

Geoff
VSTAudioEngine_64.zip (239 KB)

Try opening the ASIO Generic Low Latency Device control panel app and ensure that your device is selected in the output section. Try also toggling the exclusive mode checkbox at the top.

Thanks very much for the reply. Today I find that the sound is working now on new projects. A whole load of system updates went through last night, which seems to me to be the only difference (this also seemed to screw up the licensing in that I also had to go through the eLicenser Maintenance in order to get Dorico going again). I still don’t have sound for stuff I did yesterday, but that is not a problem for me as I was just experimenting.

So one way or another this issue is solved as far as I am concerned.

Thanks again,

Geoff

This is not the issue with the RealTek High Definition Audio device but the RealTek Windows Driver.

My ThinkPad W530 runs Hackintosh macOS Sierra using AppleHDA (with binary patch) to drive my on-board RealTek High Definition Audio (ALC269VC, Layer 3) and it sounds even better than the built-in audio on my MacBook Pro early-2015.

The RealTek audio driver for Windows is too awful. Using either ASIO Generic Low Latency Device driver or ASIO4All won’t help pretty much. You could do playback, but its audio playback quality could be a big problem (plus possible stability issues with ASIO4All). RealTek needs to reinvent their Windows driver.

That isn’t the whole story. I’ve been using RealTex + ASIO4ALL for about 5 years on Windows 7 and Windows 10. No crashes, no “driver update problems” upgrading from 7 to 10, no “awful sound quality”.

But the PC wasn’t from a “big name” consumer-equipment supplier like Lenovo, Dell, or HP…

Probably because you are lucky, just like my case of having no interface responsiveness encountered on my side. I still remember 5 years ago ASIO4All crashed like a ***** on my ThinkPad T61, constantly making my Windows 7 x64 BSOD.
Nevertheless, as long as you tried your on-board DAC under macOS (with AppleHDA but not VoodooHDA), you would never turn back. :slight_smile:

Sorry, but I’m not interested in paying Apple’s inflated prices for a computer in a prettier box than the one I already have. Especially since most people I know who do have a Mac run Windows on it when they want to do real work :wink:

Actually, we’ve had more problems on the mac than on Windows. The Realtek is just about the only device giving consistent problems.

You misunderstood my idea. Hackintosh does not need you to buy a new Mac; however, it installs macOS on your current PC. The existence of Hackintosh is to cope with the inflated prices for Apple computers. Also, real works in music industry generally get done more on macOS.

I know it is obvious. Otherwise Cubase and Wavelab should already support Retina Display in 60FPS at 4 years ago. Your cross-platform framework, if I guessed right, needs some work to perform better than the proprietary one made and used by PreSonus. // Things may be different from what Dorico currently consults, and you definitely know more than what I know about it.

I don’t know why you keep talking about FPS - it’s a meaningless measure in a desktop application. Desktop applications have a totally different update mechanism to games, and the speed of a graphics card will have almost no effect on the perceived redraw rate. The framework we use does support Retina but there are certain areas where there are extra things we need to do to go cope with multiple DPIs, some of which we just haven’t had time to do yet.

According to my experience using the purchased version of Dorico 1.0, I don’t think Dorico currently behaves bad at this criteria. And I certainly bear in mind that Dorico deserves more time to troubleshoot any of its possible derived issues in the future. What I complained is certainly related to Cubase and Wavelab (I bought them, too). In such case, does what you said “we” mean “Steinberg London” only?

I do understand what you are saying, but after a long career working with computers of all shapes and sizes for almost 50 years, to be honest I’m not very interested in tinkering at that level - especially when somebody suggests I should be using software written by Apple in an environment where Apple doesn’t support it, and which may or may not be legal in my country (I haven’t spent any time doing the research to find whether it is or isn’t), and which can only be installed via open-source projects which (I would guess) are a fairly minority interest among people who are interested in tinkering at that level.

If Windows 10 “just works” for me, the fact that there are (a minority of) people for whom it doesn’t work, or who have deep philosophical objections to it, and who make a lot of noise about their situation on the internet, doesn’t really interest me either, compared with actually using computers for some purpose that I can’t accomplish without them!

I also have a problem in that trying to set up sound drivers in Dorico the Realtek device driver doesn’t show up as one of the available options. Midi, no problem, Bluetooth to a Yamaha audio system, no problem. Generic low latency doesn’t produce audio output and Realtek output is not an option while Realtek input is. All other music/audio software accesses the Realtek driver. The excuse that it is a Realtek problem doesn’t seem likely under the circumstances.
Suggestions?

Could you please post a screenshot of the Generic Low Latency Driver Panel? In Dorico, choose Edit > Device Setup, select GLLD and then click on ‘Device Control Panel’. Alternatively execute the program C:\Program Files\Steinberg\Asio\asioglldsetup.exe

As you can see there’s nothing in the window at all…
RealtekAsioIssue.png

Yes, and that exactly is the reason why you don’t get any sound, because the driver doesn’t know where to send the audio data out to.

Now, if you untick the radio box “Allow ASIO host application to take exclusive control…”, does then the Realtek output port appear?

Makes no difference.

Here’s the result with bluetooth running
Asiowithbluetooth.png

Then something is wrong with your Realtek device (or it’s setup).

If you open the Windows Device Manager, what does it say in regards to audio inputs and outputs?
I’ve attached a screenshot of how it looks on my machine.

In case you don’t know, hit the Windows Key and type “device manager”, then return and the Device Manager will open.
Realtek.png

And Ulf in Windows 10 are you aware you only need to use the right mouse button over the Windows Start Icon to bring up a context window which includes the device manager…