No playback; speakers not found; driver stuck on 48kHz

I have recentlly installed Dorico 2, and now have playback problems (not neccessarily as a result of the new installation, but I wonder; playback worked before then). In Play mode, the playhead moves. But when I go to Device set-up the Generic low latency ASIO driver is shown, but with a sample rate of 48K, and this can’t be changed. In Device Control Panel, the built-in speakers are not in Output ports (nothing is). The piano sound is loaded in Halion Sonic SE, but the piano keys do not respond and the lights at the top of the window do not light up.

I’m running Windows 8.1 x64 on a Toshiba loptop. The built-in speakers use ITC High-Definition Audio CODEC. The sample rate here can be altered easily (but is currently set at 41kHz; changing it to 48kHz is possible but doesn’t cure anything).

Attached are a short project for the purpose of sorting this out, and the VST64 folder.

It’s all rather a mess and would appreciate help; this stuff is all rather techy for me!

Michael (252 KB)

Have you tried unchecking the box for exclusive control of the ASIO device at the top of the Generic Lower-Latency ASIO Driver control panel?

The other thing worth trying is working through the steps in Ant’s playback troubleshooting video.

I’ve confirmed this here with my setup, but it is the other way round. If I tick “exclusive control” then I get a list of available sample rates, but if I untick it, then I only get 44.1kHz. Please also not, after ticking or unticking the checkmark, you have to restart Dorico. Only after restart (or driver change) the audio engine interrogates for the available sample rates of the audio device.

Thank you, both of you. I have watched the video (several times!) and I’ve taken the steps described in it. I can now choose the sample rate in the Device Manager, and got both that and the speakers set to 44.1kHz. But I’m still left with the other two problems: in Halion SE3 playing the piano keys at the bottom of the window produces no activity - the level meters don’t light up and of course there’s no sound; and in the Device Manager the playback devices box is still empty. I don’t understand why Halion SE won’t do anything, nor why Dorico can’t see the speakers.


Can you please, again, zip up the VSTAudioEngine2_64 folder and post here. Also, please include include a screenshot of the Generic Asio Driver panel.

Dear Ulf

Here they are.

Device control panel 06-06-2018.png

This seems to have been lost in transit:

VSTAudioEngine2_64 (2).zip (252 KB)

In that control panel, untick the topmost option “allow exclusive access…”. When you do that you should see one or more audio ports in the list of output ports. Make sure that then the output port is selected, close the panel and restart Dorico. You shall then get sound.

Ulf - thank you very much, everything is now working. I don’t kow how it got into such a muddle, and the way out isn’t intuitive (to me, anyway - “tick this box”, “untick this box” … and I haven’t the faintest idea what all the buttons and knobs in Halion Sonic do), so I’m very grateful for your help.


No worries, that’s what we are here for: helping people to get the most out of Dorico.