No playback with Noteperformer 3

Hi all,

I’ve installed Dorico 2 as well as Noteperformer 3 but NP isn’t showing as a VST instrument in the panel in the play menu. It shows up as a playback template and I’ve made it the default as far as that goes but get no sound because it isn’t registering as a VST instrument. Is there something I should do beyond the standard installation? NP3 shows up and works fine with Sibelius.

Thanks!

Have you read the quick start guide for Noteperformer here?: https://noteperformer.com/?page=support_dorico
And have you read this thread, end to end? https://www.steinberg.net/forums/viewtopic.php?f=246&t=138773

edit: are you definitely running Dorico 2? Dorico 1 and 2 can coexist on the same computer, and installing Dorico 2 doesn’t automatically remove Dorico 1 or shortcuts to it…

kwaselewski,

Given that the interface between Dorico 2 and NotePerformer 3 is still to be regarded as under development (in beta), it seems to be necessary not to try and ‘apply’ NP settings to an existing score; that doesn’t always work.

I have had success, setting up the players with blank scores then (if necessary) changing the places (Preferences and Play drop down, right hand side) where you need to change to use NP. and only then pasting a score back into the new (effectively blank, with only the meter (SHIFT-M) set) 'template. Good luck!

Make sure Dorico 2 isn’t running, and try running the NotePerformer 3 installer again. NotePerformer could be on Dorico 2’s blacklist by accident. Running the NP3 installer should normally resolve blacklisting issues, but it would only work if you have Dorico 2 closed while installing.

If that doesn’t work, you may have to try and trash the VstAudioEngine2/ folder manually (again, when Dorico 2 is closed). Where to find it depends on whether you are on Mac or PC.

On windows: %APPDATA%\Steinberg\VSTAudioEngine2_64

On mac: ~/Library/Preferences/VSTAudioEngine2