No reply after creating a support request for 10 days


I’ve created a support request (eLicenser issue), but haven’t received a reply in 10 days. What do I need to get this resolved?

Best regards,

Hi and welcome to the forum,

Could we (the users) help you here?

As you set the ‘Cubase-13’ optional tag, let me inform you, Cubase 13 is not using eLicenser anymore. It is using the Steinberg Activation Manager.

Thanks for your reply. I’ve bought an upgrade from Cubase 10.5 → Cubase 13, but my eLicenser is lost/broken. Now I’m not able to upgrade.
And still no sign of life from Steinberg support after 12 days…


There is a way to proceed with the lost USB-eLicenser.

Please, get in contact with your local Steinberg Support, whose is in charge.

Sorry, @DelicateDonkey, I just checked the status and there is a support agent assigned and you should have receive a reply this morning.

I reached out to the support agent who helped me with my lost/broke USB-eLicencer. He helped me to resolve this. Still strange that my original support request is still unanswered, I think. At the moment I’m unable to verify my e-mail address it seems, so am not able to check my support request.

403 Forbidden

Attempting a prohibited action

Tried to logon to the support case again, today I was successful. My issue was resolved, and so are all my support cases ;-).
It has been resolved by a very helpful support employer at the “lost/broken USB-eLicenser” team, it took the “normal” support desk over 15 days to even reply. (Which by then was resolved).
Anyway, I’m a happy camper now. :wink: