No response from support on "No License To Upgrade Selectable"

First of all; any advice on what to do when Steinberg support hasn’t answered? It’s been 18 days.

Meanwhile I try here. I checked similar posts but I was not able to make it work. Was not able to transfer from USB to new license system.

I bought
WaveLab Pro 11.1 Update from WaveLab Pro 10 / Download Version

I can redeem an activation code, I see both the USB license key and the soft license in the eLicenser Control, but is says “No License To Upgrade Selectable”. Details:

I am a Wavelab user since many years. I have been really patient with all the steps/utilities and spent a lot of time and tried my best to go from the USB to the e-licensing and I even thought I had done it it seems something is missing (I think I was fooled by a 30 days trial period even though I own a license). I searched for guidance and followed and
No license to upgrade selectable - #34 by andriusv (people really struggle…)

, including entering the download access code in the Download Manager (when it finally started OK after server not responding yesterday). But it says “No License To Upgrade Selectable”. Please see screenshot.
The USB key license worked for running Wavelab 11.1 but not 11.2 (where it is no longer supported), so I think the key as such is fine still.
Please help me get to work again!
Macbook pro M1 2020 Big Sur 11.6


There was a first response by the support after 26 days. In the end we worked out that it was my fault, I had inserted a different USB eLicenser than I thought I had.