No signal from mic

I have just installed UR22 using my old Macbook (10.6) and garageband (because Cubase won’t load) to test the setup before buying a new Macbook.

Recorded music from GB plays out fine (via speakers), but my mic (SM58 which works perfectly) does not go live. The peak light does not come on when turned all the way up and there is no sound at all.

I have tried both phone jack and XLR connections.

Have you switched on 48v Phantom power? It’s a switch on the back of the UR-22 and an LED light will come on at the front when it’s activated.

SM58 does not need Phantom power, but it does not harm a dynamic microphone too. Never do this with a ribbon mic though.

Maybe this can help ?: (i do not have garageband)


kind regards,

I have now upgraded my MacBook Pro to 10.10.5 and connected UR22. iTunes plays out fine through UR22 to speakers, also keyboard, but mic still dead. I must be doing something wrong!

Thank you roel for links to GB help, but the problem is the same with GB and cubase. Anyway, the mic should work independent of DAWs when connected to audio interface.

I have now tried using an XLR adaptor and do get a mic signal. It is weak, but with input gain all the way to the right and pretty loud output, it is useable. Disappointing, though.

Send it back under return policy and take a condenser microphone.
It doesn’t (have to) cost as much as a SM58 and you will be amazed what diffference it will make. (a condenser needs phantom power)

example europs:

other example:

Both are extreme bang for the buck, and will record your beautifull voice with every detail.
SM58 is a dynamic microphone and is useable for studiorecording, but is more intended for live.

kind regards,

Thanks, Roel. I’m putting those on my wish list (so many things to buy!)

Right now I am preoccupied with a midi file problem (see next post).