No sound during playback in Dorico

Hello,

I have installed Dorico element 3 on my Pc and I can’t hear any sound during the playback. I have downloaded the Halion Sonic SE. I haven’t sound when I click on “edit the instrument” and there is this page with a piano.
Can someone help me?
Thank you
Trist531

Under Edit > Device Setup, what ASIO driver do you have selected.
Also, when you create a new project from piano template, please choose Help > Create Diagnostic Report. That creates a zip file on your desktop. Please attach it here. Thanks

Hello,
Thank you for your reply. I have the “Generic Low Latency ASIO driver”.

Trist 531
Dorico Diagnostics.zip (315 KB)

The Generic Low Latency driver is selected, but the driver can’t “see” any output ports, so it does not know where to stream the audio out to.
Open Edit > Device Setup and in that dialog press the Control Panel button, another little window opens.
At the top of that window is an option called something “Allow ASIO host to take exlusive control…”
If you toggle that, does a little below in the output port list appear something.
If yes, you are lucky, choose that port by making sure that it is checkmarked at the front.
Then close all windows and restart Dorico. Does then sound come out.
If not please attach a new diagnostic report.

If still no output ports turn up, you might try ASIO4All (http://www.asio4all.org/) another free generic driver.

I toggled “Allow ASIO host to take exclusive control” but when I quit that window and come back to the control Panel button, it resets.
I have this.

Then you need to change a setting on Windows side.
In your taskbar is a little speaker icon, right click it and choose Sound Settings. Then select the Speakers and push ‘Device properties’, then ‘Additional device properties’. A new little window opens, in there choose the ‘Advanced’ tab. There is also an option that says “Allow apps exclusive control”, make sure that one is also ticked.

Okay, it is ticked.


Okay, but if that is ticked and the other one in the driver control panel always gets reset, that means to me, that another application is open and is accessing the output ports exclusively. Try to close any other application but Dorico and see how it behaves then.

It doesn’t reset anymore but I still don’t have any sound.

Please post another diagnostic report

There it is.
Dorico Diagnostics.zip (340 KB)

Okay, at least now the driver uses “Speakers (Realtek High Definition Audio)” as output ports, so that’s at least a little success.
Actually now I would expect audio to come out.

Please do the following:

  • Create a new project from piano template
  • Enter a handful of arbitrary notes
  • Got to Play Mode and open the HALion Sonic SE editor window.
  • Click with the mouse on the shown on-screen keyboard. Does then sound come out?
    If not, is at least some metering flickering at the top middle of that screen? That would at least indicate that the audio engine as such is processing audio.

Yeah, I got sound on the show on-screen keyboard.

Great to hear. Is now everything settled for you or still some issue?

I hear the sound on the shown on-screen keyboard but still not during playback and input.

Okay, then try following:

  • Choose ‘Edit > Device Setup’
  • In that dialog set a different sample rat, wait a few seconds and then set it back to the old value
  • Wait again a few seconds and close the dialog.
  • Try playback again. Does the green line move then, does sound come out?

:(The green line is moving without sound and I only have 48000 sample rat.

Hi, I noticed that There were sound, but only with certain projects (for exemple :Coldplay clocks.dorico). I don’t have sound with new projects. Is it normal?

Ah, then I know what your problem is. You don’t have the HALion Symphonic Orchestra Library installed (or Dorico can’t “see” it).
Have you downloaded and installed the ‘Dorico Pro Sounds Installer’? It’s quite huge, around 9GB, but you need that for a decent playback.

Okay, I hadn’t downloaded it. But how do I installed it?