No Sound Ever so far!

Hello from Cape Town, my friends.

Since installing Dorico for the first time until today, I don’t have sound in Dorico. The VST interface does not have playback neither does Dorico play back my entered music.

Here is an unlisted video of my problem.
Attached is a pic of my MIDI Controler.

https://www.youtube.com/watch?v=ED7kD9NDMqA

Thanks guys
Regards
Hans
Keyboard.jpg

I scrubbed my way through your video, Hans, so I may have missed it, but if you click and drag the modulation wheel in the HALion window so that it’s not set to zero, and then click on the keys on the keyboard in the HALion window, do you now hear any sound?

It looks like everything is basically setup as it should be. Are your monitors connected to the first stereo out on your Focusrite interface?

Same problem here. The “Low Latency ASIO Driver” which comes with Dorico works sometimes (sometimes not, even after a restart) on my Surface 3 Pro, as long as I don’t change the output to Earphones. From that moment no sound is hearable, even when I switch back to speakers. Also: EVERY other ASIO driver (ASIO4ALL and FastTrackPro ASIO) produces no sound at all. In other host applications all works as expected.

Hi Daniel, no joy, unfortunately :frowning:

I am so eager to hear the HALion library…

My setup is fine because everything works fine in Sibelius, or YouTube videos, MP3 etc.

Peady said something interesting/curious…

He refers to the Surface Pro. So we might get a clue here. I don’t have sound in Dorico AND StaffPad and Dave is also puzzled by it. Is there maybe a Windows 10 dll or API that might cause this?

I also attached the Sound folder as suggested by you in another post.

Regards
Hans
HALion Sonic SE_64.zip (10.8 KB)

I’ve had the same Problem with existing Projects. New Projects from Templates worked well. I solved the Problem by deleting all Connections (VSL Ensemble) in Dorico and set them up new.

Good morning my friend…

The problem is, as you will see (in the video) exists even when I load a new project from a template.

Normally in a DAW, one can assign the inputs and outputs for a track. I don’t see, anywhere, where I can direct the VST plugin to accept input from my MIDI Controler. The output is obviously the soundcard, but WHERE do I tell Dorico to get it’s input from my MIDI Controler. In other words…if I press the keys on my Controler keyboard, like in PLAY for instance, the small keyboard at the bottom of the VST shows the keys I press. But as you see in the video, notes are entered into the score…which tells me that Dorico IS getting MIDI messages from the Controller, but the VST instance does NOT display ANY message whether it is the little keyboard at the bottom, the lack of VU meter display or hearing any audio. It’s as if the VST instance is dead…NO connection between the host and the VST! :open_mouth:

I was thinking of trying my EWQLSO Library to see if it will do something…but HOW/WHERE do I direct Dorico to my PLAY VST Folder?

Hans,

could you please create a new Piano project, add a handful of arbitrary notes, save it and then post it here.
Probably you first need to zip the project as .dorico files may get rejected.

Cheers,
Ulf

Will do, sir.

Just for fun I tried to install Dorico 1.0.10 on my Surface Pro, fully updated Win10. Dorico is totally silent with both the Generic and Asio4all drivers, but Staffpad plays fine…

Good afternoon Ulf…

Herewith is the piano zip file as requested.

I have some important info in this YouTube Video.

https://www.youtube.com/watch?v=8dJLuHAkTug

Best Regards
Hans
Hans Piano Test.zip (202 KB)

Hi Hans,

looking at the project file’s data, I can clearly see, that you won’t get any sound from Dorico, because Dorico didn’t recognize any audio output port. Only the following input ports:

But the inputs are irrelevant to Dorico, it’s of course the outputs that matter. But because it can’t find output ports, the audio engine can’t be connected up and so HALion will sound into void.
From the video I see (or you say) that EastWest is playing through your Focusrite. Is it possible that EastWest is exclusively using the outputs and that Dorico then can’t connect to them?
What if you do the following:

  • Quit any other app
  • Start Dorico and make sure again, that Focusrite is chosen as driver
  • Create another, new empty Piano project (with really just few random notes)
  • Then save it and post it here again

Cheers,
Ulf

Hi Ulf, I understand what you mean…but as you saw, PLAY was NOT loaded when I started Dorico…so I’m not sure WHAT took exclusive control of the output ports. I only loaded PLAY later in the video.

But, cool, I will do the piano part again. I will ensure NOTHING that could possibly use the Focusrite is running…except of course if Windows has some use of it somewhere like Cortana or something. Is it possible that Google Chrome or another browser also take exclusive control over the ports. I did actually disable Focusrite’s exclusive functionality. See Pic.

Ulf…one more thing as I do your bidding…I try to add:

play_VST_x64
565354706C6179706C61795F7673745F

to the Whitelist text file but the text file will not save…it reports “Access Denied” and I AM the admin. I save text files every day. And Dorico is NOT running so it can NOT be Dorico that causes the text file NOT to save. Sorry for asking this here but I seem to monopolise the forum so I hope you would be so kind as to advise as we are talking right now. :slight_smile:

Ok, let me create the piano part again.
Capture.JPG

Hi Hans, okay, close Dorico and have a look in the TaskManager for a process called VSTAudioEngine. If one (or more) still hang around, kill them and then try saving the whitelist again. Because Dorico at start-up also launches that VSTAudioEngine process and that is actually the one that accesses the whitelist.

Hi Ulf,

Ok, here is the piano file. NOW everything works!

Are you telling me I cannot have an internet page or something open when I use Dorico?

I’m just asking because when I use Sibelius and I often have a video open in a player because I arrange music from a video or MP3?

Now, as you can see in the 3 pics, I exited EVERYTHING I thought that could possibly use the Sound Card.

Regards
Hans
Hans Piano Test.zip (198 KB)

Hi again Ulf, it seems that my Video player might have been the cause for Dorico not sounding notes because (with Dorico running and having a playable score) I opened my video player and now THAT thing does not play any sound!

That’s a pity because (like I said) I use my Notator ( Sibelius thus far) and the player constantly when I write music. So now ONE of them has to go! :frowning:

THAT is why I disabled exclusive control in the Focusrite Properties Dialog. Then BOTH will/should be able to use the sound card.

Anyway, Dorico is more important, so I’ll just have to find another solution.

THANK YOU SO MUCH FOR YOUR HELP!!! You guys ROCK!! :slight_smile:

Hans

Ehm, actually, for me it works. I can watch YouTube videos and get sound out of both, YouTube and Dorico at the same time. This holds true for the built-in sound chip (via the GLLD driver) as well as for my UR22mkII.

I would expect it to work also in your case. In the task bar, you should have the volume control on the right. Right click on it and open the Volume Mixer and Playback Devices dialog. Is there something unusual?

Hi Ulf…

Uhm…The video player was muted! :blush: Ok, now go ahead and say it! :smiley:

I muted the mixer on the right because when Dorico started to play…it almost blew my earphones off my head. FFFFF! I did that on instinct but forgot to turn the volume back up.

Still, What was the actual problem then if it was not the video player? Because that’s all I did, I exited Chrome and the video player and then Dorico worked. WOW…A miracle?

Your UR22mkII looks very similar to the Focusrite! You are welcome to donate it to our school when you upgrade to a better model. :sunglasses:

Everything is cool now!!! THANK YOU!! :smiley:

Hi Hans,

I had to laugh out loud when reading your last post, you have a good sense of humor and can even laugh about yourself. Stay like that. I also liked your video.

And glad to hear that everything’s now working with you.

Best
Ulf :slight_smile:

Thanks Ulf!

They way you described my character is actually very accurate and short of puffing my mind up with an ego, this character trait (or perhaps charisma) does help me extremely much when I conduct orchestras and concert bands. Normally musicians cannot wait for me to get at the conductor’s podium because they know the rehearsal is NOT going to be boring.

But, I picked up a similar character in YOU…"…Ehm, actually, for me it works…"

It’s always a pleasure to chat and meet kindred souls. Please, Ulf…keep making us proud.

Here’s another one for the road… Trump was correct. American businessmen are stupid! I agree…they only fired the world’s BEST of the BEST and all WE had to do was bookmark a new internet site!

Keep well my friend! :slight_smile:

Thanks, Hans. You too. :wink: