no sound in Dorico Elements 3 - crazy making

I just bought Dorico Elements 3, and I’m flummoxed by how to properly install the sounds. I’ve looked at past threads and the Dorico video on sound, all of those are for previous versions and the sound thing has been redone in version 3. I hope you will forgive me for posting.

The first thing I did was install the two things that were presented to me in the installation manager, taking the defaults. There was a third thing, which just took me to a version history on a web page. Fired up Dorico - no sound. Poked around a while trying to figure it out on my own, no joy.

I did notice that by default the sound installation part installed under the download location, rather than where the application goes by default (without being funny, that’s a big bug!) So I uninstalled from there and tried reinstalling under the directory where the application gets installed by default. I’m on Windows 10 and C:Program Files is still a thing. But that hasn’t helped. No sound, no joy.

I read up on old forum posts and the Dorico sound troubleshooting video. As a result of that…

I’ve tried reinstalling, uninstalling and reinstalling, reeling and writhing and fainting in coils, and so far the results are all the same. No sound.

I panicked and downloaded and installed the standalone version of Halion SE, no joy. I figure I’m probably just cluttering up my system now, so I need some guidance.

My symptom is, there is nothing under VST instruments in play mode. I’ve tried everything I can think of or find online to fix it, and no joy.

Help meeeeeeeee…

Yours, Elenmirie

Welcome to the forum, Elenmirie. I’m sorry you’ve had problems getting the sounds installed. If you try to run Steinberg Library Manager via the Cortana search box, are you able to run it? What libraries does it show as being installed? This will tell us whether any of the sounds are properly installed or not.

Hi Daniel,

Thanks for your welcome - sorry the first thing I’m doing is moaning. :wink:

Here’s a screenshot of my library manager:

Thanks. So the required sound libraries for Dorico Elements are installed and should be “seen” by Dorico, yet still no sound…
Therefore, to get a better picture, please create a new project from the piano template, enter a handful of notes and then from the main menu choose Help > Create Diagnostics Report.
That creates a zip file on your desktop, please attach that here. We’ll have a look at it and come back with more questions then.

Hi Ulf,

Here you go. As I said in my original post, I’ve got nothing showing in the “VST Instruments” panel.

Also, when I tried this before, the cursor would move when I pressed the play button. This time, it doesn’t. I don’t know if that’s significant or not.


Dorico (268 KB)

Hm, this also might be a clue. I tried saving a file and reopening, and got an error message (see attached screenshot)

Hi Elenmirie, looks like yours to become yet another difficult case…
So from the log data I can see that you have the appropriate plug-ins and sound libraries installed and Dorico can “see” all of them.
But there are 2 major problems:

  1. You are missing the playbacktemplate files, by which Dorico will load the pertinent VSTinstruments and sounds
  2. You have no sound driver set.

Regarding the playbacktemplate, I don’t know how it comes they are not installed. Also, I don’t know enough about this area, so someone else like Daniel needs to help.
And since you ran the installer and they are not there, you might need to install them by hand, don’t know.

Regarding the sound driver, it does look like the Generic Low Latency Driver is installed on your system and Dorico tries to use it,
but then it always falls back to no driver at all. Now, I want you to go to Edit > Device Setup, what is shown there?
Is the Generic Low Latency ASIO driver selected? If not, can you select it in the drop down list?
If it is selected and you click on ‘Device Control Panel’ a new little window shall appear with the title “Generic Low Latency Driver Version - x64”.
Could you please take a screenshot and post here? Thanks.

So with these two conditions it is no wonder that you don’t hear anything.
If there is no VSTinstrument loaded or no audio driver selected, it’s impossible to get sound out.
But trust me, sooner or later we will get you there.

Ulf, I seem to recall a second download and installer for the VST instruments? At least in the PRO version? Maybe that’s what he is missing? Just trying to help a brother composer…

gdball, you’re right that there used to be two sounds installers (in Dorico 1 and Dorico 2), but in Dorico 3 they’ve been combined into one.

Hi Ulf,

I’m sure I saw the driver in that dialogue box before, but now there is nothing. Screenshot attached. There’s no dropdown that comes up either, so I can’t select anything.
Dorico device setup.png

I kept getting this error, fixed it by going to the play menu and selecting a playback template. And ‘apply’.

Didn’t have any issues with the sound driver though.


elenmirie, if you choose Play > Playback Templates, do you see any options listed in there? For Dorico Elements there should be one entry, HSSE (Elements). Try selecting that in the list and then clicking Apply and Close at the bottom of the dialog. Then hopefully you will see HALion Sonic SE load in the VST Instruments panel on the right-hand side.

Okay, that worked, and I now have teh HALion Sonic SE in the VST instruments panel.

Still no driver though. Is there a way to just install the driver? How would I do that?


Uh, that’s bad. Never seen something like this before, but anyway, please take a look at C:\Program Files\Steinberg\Asio
Do you have that folder on your computer and does it contain 2 files called asioglld.dll and asioglldsetup.dll ?
Those 2 files should have gotten installed together with the Dorico installer.
If they are not there then I suggest that you run the Dorico installer once more and use the repair option.

Hi Ulf,

No, I don’t have that directory at all. Trying your suggestion.

Progress report:

  • I chose the “reinstall” option; there was no repair option so I reckon that’s what you meant
  • The reinstall refused to work until I closed the download manager, as it was also using the licensing system (tsk, tsk)
  • I got a popup saying I needed to restart my system for the changes in Dorico to take effect. I pushed the “okely dokely” button, but just before my last thought faded, I caught a glimpse of another dialogue that said “Dorico Installation Failed” and of course I had no time to read the rest of it, as my system was in the throes of restarting.

Now I’ve rebooted and am about to Try, Try, Try Again ™

Nope. I started a new project, added a piano, put in a few melancholy notes in a minor key, and pressed play. No joy.

I had the same situation again - no instruments in the VST instruments, and no driver. Now, I was able to get the instruments back by repeating what I’d done before - the play templates thing. I still don’t know how to get the driver back.

Just as a matter of interest, I found a thread on the forums that talks about a similar problem, they were able to find it in the Cubase directory. I tried poking around to find it in the Dorico one but no joy. Is there a way to just reinstall the driver?

Let me try this again, and this time I’ll be slower on the reboot trigger so I can capture that installation failed message.

Thanks again!

Right-ho, now I’ve hit the uninstall button. It doesn’t seem to uninstall cleanly. I’ve still got stuff hanging around in the steinberg directory. OK, experiment one, leave it alone and try installing Dorico again. if that doesn’t work, experiment two will be to uninstall again and manually remove all the remaining gubbins that I can find, then reinstall.

My fear is that there’s stuff hanging around in the registry that will thwart my plans.

Okay. The attached screenshot shows my current state. I repeated the step about the playback template, and I’ve got the driver now. But still - no sound.

Also I had to slam it because it stopped responding. blubber

Now I started up the program again, I had to yet again do the playback template thing (am I going to have to do that every time I start the program?)

One little bit of progress. The cursor moves now when I hit play. No sound, but the cursor moves.

So, I’m sort of back to where I was when I started. The cursor moves, but no sound. The cursor moves… but no sound. No… sound… but… cursor… moves. Cursor moves. Small victories!

I’ve got to give up for the night. The tenuous grip I still have on sanity is starting to slip away.

But you are getting closer now. See, the Generic Low Latency driver is now installed, because you get now that driver panel window.
What is missing now, the driver does not see any output ports, where it could stream the audio out to.
At the top of the driver panel is an option ‘Allow ASIO hosts application to take exclusive…’
Tick that option and see if in the middle of that window then an output port appears.
If it does you are lucky. Make then sure that the little box is ticked in front of the name.
Then close the window and also restart Dorico. If in the Device Setup dialog the port names appear you got it,
sound shall come out during playback.